[ovs-discuss] OVS-OFCTL - negotiated OpenFlow version

Manik Sidana maniksidana019 at gmail.com
Fri May 8 12:39:00 UTC 2015


Hi Vipin,

Which version of OVS are you using.
Check this link for your OVS version:
 http://openvswitch.org/pipermail/dev/2013-June/028026.html

Thanks
Manik Sidana

On Thu, May 7, 2015 at 3:22 AM, Vipin Garg <vkg.2006 at gmail.com> wrote:

> Hello,
>
> I am trying to update the status of one of the port using following
> command -
>
>
> data2 # ./ovs-ofctl mod-port  vlan20-odl sp4 up
>
> And I got following error message ...
>
> 2015-05-06T20:52:49Z|00001|vconn|WARN|unix:/usr/local/var/run/openvswitch/vlan20-odl.mgmt:
> version negotiation failed (we support version 0x01, peer supports version
> 0x04)
> ovs-ofctl: vlan20-odl: failed to connect to socket (Protocol error)
>
>
> As suggested on some mailing list, I added openflow versions as follows -
>
> ./ovs-vsctl set bridge vlan20-odl
> protocols=OpenFlow10,OpenFlow11,OpenFlow12,OpenFlow13,OpenFlow14,OpenFlow15
>
> and then again update the port ..
>
> ./ovs-ofctl --verbose mod-port  vlan20-odl sp4 up
>
> In the logs, I see that --
>
> 2015-05-06T21:39:55Z|00015|vconn|DBG|unix:/usr/local/var/run/openvswitch/vlan20-odl.mgmt:
> negotiated OpenFlow version 0x01 (we support version 0x01, peer supports
> version 0x06 and earlier)
>
>
> My question is -
>
> 1. Why the negotiated OF version is 1 (not 1.4) when peer (OpenDayLight )
> can support higher version
> 2 How can I make  trained OVS to communicate using higher version of OF ..
>
> 3. Why I still don't see port status getting update , Am I missing
> something ?
>
> Thanks
>
> Vipin Garg
>
> Fortinet ..
>
>
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150508/a9be2b42/attachment-0002.html>


More information about the discuss mailing list