[ovs-discuss] openvswich freebsd 10.1 release configuration error

Joe Stringer joestringer at nicira.com
Fri Nov 13 07:27:00 UTC 2015

Hmm. The package should provide vswitch.ovsschema somewhere, but I'm
not familiar with FreeBSD or how this particular package is

The other thought I had is that the "No such file or directory" could
be referring to /var/db/openvswitch rather than the

I've CC'd kevlo, who is listed as the maintainer for this port (if I'm
not mistaken). Perhaps he can point you in the right direction.

On 12 November 2015 at 13:05, Hassan Samii <hassan_samii21 at yahoo.com> wrote:
> The OVS deamons are not running because there is no initial configuration.
> When i launch the command
> ovsdb-tool create /var/db/openvswitch/conf.db
> /usr/local/share/openvswitch/vswitch.ovsschema
> even if i change the prefix as you said i still get the "No such file or
> directory" error.
> I also tryed "whereis vswitch.ovsschema" and it doesn't find anything.
> I think there's supposed to be a folder called openvswitch which should have
> the db settings and all but apparently it doesnt exist.
> Il Giovedì 12 Novembre 2015 19:43, Joe Stringer <joestringer at nicira.com> ha
> scritto:
> On 12 November 2015 at 01:45, Hassan Samii <hassan_samii21 at yahoo.com> wrote:
>> Hi everyone, Firstly i'd like to thank everyone for the amazing work that
>> your doing.
>> To my problem.
>> I installed Open vSwitch on a FreeBSD 10.1 Release (which resides on a
>> virtual machine working on Virtualbox). I used the Freshports to install
>> openvswitch and the installation completed successfully.
>> Now the problem is that if i do ovs-vsctl --version i get the following
>> (which i suspect is good):
>> root at FreeBSDPrimo:~ # ovs-vsctl --version
>> ovs-vsctl (Open vSwitch) 2.3.2
>> Compiled Nov  4 2015 16:39:41
>> DB Schema 7.6.2
>> but if i use the command ovs-vsctl show i get the following (which is not
>> good):
>> ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed
>> (No
>> such file or directory)
> Are the OVS daemons running at this point (ovs-vswitchd, ovsdb-server)?
>> So then i thought that the configuration do the db was not set so i tried
>> this and got the following error:
>> root at FreeBSDPrimo:~ # rm -f /var/db/openvswitch/conf.db
>> root at FreeBSDPrimo:~ # ovsdb-tool create /var/db/openvswitch/conf.db
>> /usr/local/share/openvswitch/vswitch.ovsschema
>> ovsdb-tool: failed to read schema:
>> "/usr/local/share/openvswitch/vswitch.ovsschema" could not be read as JSON
>> (error opening "/usr/local/share/openvswitch/vswitch.ovsschema": No such
>> file or directory)
> I suspect that this port of OVS is configured with /usr as the prefix,
> not /usr/local. So the path to the latter would be something like
> /usr/share/openvswitch/vswitch.ovsschema.

More information about the discuss mailing list