[ovs-discuss] Bridge traffic stops flowing after ovs-vtep run

Guru Shetty guru at ovn.org
Wed Nov 25 18:04:22 UTC 2015


On 23 November 2015 at 09:11, Mikhail Bagrov <mbagrov at cloudlinux.com> wrote:

> Hi. I'm trying to implement the VTEP Emulator from
> https://github.com/openvswitch/ovs/blob/master/vtep/README.ovs-vtep.md
> I've built OVS from source on Centos7, trying to interconnect docker
> containers between different and within a single docker node. Still no
> traffic flows between containers.
>

Debugging a VTEP emulator is a step by step process. How familiar are you
with openflow flows? i.e. do you understand what 'ovs-ofctl dump-flows br0'
says? When you ping from your docker container do you see a particular flow
stats getting incremented ?


>
> I have:
> [root at ovs11 ovs]# vtep-ctl list-remote-macs ls0
> ucast-mac-remote
>   7a:2c:ba:c0:62:16 -> vxlan_over_ipv4/10.2.2.102
>   c2:fd:9f:ea:3f:e3 -> vxlan_over_ipv4/10.2.2.101
>   de:eb:3c:62:65:fc -> vxlan_over_ipv4/10.2.2.103
> a mac to ip mapping table populated on each host.
> [root at ovs11 ovs]# ovs-vsctl show
> 82434185-c196-45dd-bcf1-1260e33ceae3
>     Bridge vtep_bfd
>         Port "bfd10.2.2.101"
>             Interface "bfd10.2.2.101"
>                 type: vxlan
>                 options: {remote_ip="10.2.2.101"}
>         Port "bfd10.2.2.102"
>             Interface "bfd10.2.2.102"
>                 type: vxlan
>                 options: {remote_ip="10.2.2.102"}
>         Port "bfd10.2.2.103"
>             Interface "bfd10.2.2.103"
>                 type: vxlan
>                 options: {remote_ip="10.2.2.103"}
>         Port vtep_bfd
>             Interface vtep_bfd
>                 type: internal
>     Bridge "vtep_ls1"
>         Port "vx2"
>             Interface "vx2"
>                 type: vxlan
>                 options: {key="0", remote_ip="10.2.2.102"}
>         Port "vx1"
>             Interface "vx1"
>                 type: vxlan
>                 options: {key="0", remote_ip="10.2.2.101"}
>         Port "0000-p0-l"
>             Interface "0000-p0-l"
>                 type: patch
>                 options: {peer="0000-p0-p"}
>         Port "vx3"
>             Interface "vx3"
>                 type: vxlan
>                 options: {key="0", remote_ip="10.2.2.103"}
>         Port "vtep_ls1"
>             Interface "vtep_ls1"
>                 type: internal
>     Bridge "br0"
>         Port "p1"
>             Interface "p1"
>         Port "br0"
>             Interface "br0"
>                 type: internal
>         Port "0000-p0-p"
>             Interface "0000-p0-p"
>                 type: patch
>                 options: {peer="0000-p0-l"}
>         Port "1d53fed7f9284_l"
>             Interface "1d53fed7f9284_l"
>         Port "p0"
>             Interface "p0"
>
> Port "1d53fed7f9284_l" is a docker container's port.
> Settings look fine, but still no traffic flows. Thanks in advance.
>
>
> --
> Regards, Mikhail Bagrov
> DevOps at Kuberdock
>
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20151125/9133a3d0/attachment-0002.html>


More information about the discuss mailing list