[ovs-discuss] RSTP crash in Open vSwitch

Daniel Swahn daniel.swahn at clavister.com
Thu Oct 1 09:13:51 UTC 2015


> Did you try Daniele’s patch alone (i.e., without my patch). It seems to me that both patched should be necessary, but I’d like to know if you tried Daniele’s patch without mine to be sure.

I did not. Unfortunately we're running low on hardware so I had to lend away the machine I was testing on. Should I test with just "daniele’s patch" once I get it back?


-----Original Message-----
From: Jarno Rajahalme [mailto:jrajahalme at nicira.com] 
Sent: 2015-09-30 22:47
To: Daniel Swahn
Cc: Daniele Venturino; Ben Pfaff; bugs at openvswitch.org
Subject: Re: [ovs-discuss] RSTP crash in Open vSwitch

Daniel,

Did you try Daniele’s patch alone (i.e., without my patch). It seems to me that both patched should be necessary, but I’d like to know if you tried Daniele’s patch without mine to be sure.

  Jarno

> On Sep 30, 2015, at 3:45 AM, Daniel Swahn <daniel.swahn at clavister.com> wrote:
> 
> The issue seems to have been solved! I'm using yours and Jarno's patch and now the system boots up without crashes. Thanks!
> 
> -----Original Message-----
> From: Daniele Venturino [mailto:venturino.daniele at gmail.com] On Behalf Of Daniele Venturino
> Sent: 2015-09-30 10:54
> To: Daniel Swahn
> Cc: Jarno Rajahalme; Ben Pfaff; bugs at openvswitch.org
> Subject: Re: [ovs-discuss] RSTP crash in Open vSwitch
> 
> I tried the commands you listed but I was not able to reproduce this in a simpler setup only with RSTP enabled on the bridge.
> 
> I’m attaching a patch I’d like you to try. I’m not really expecting much from it, but can you give it a try since I can’t reproduce this?
> 
> Daniele
> 



More information about the discuss mailing list