[ovs-discuss] [ovs-vsctl]

Murali R muralirdev at gmail.com
Wed Oct 21 23:24:22 UTC 2015


The logs

Oct 21 23:04:27 sc-nc ovs-vswitchd: ovs|00020|memory|INFO|2472 kB peak
resident set size after 10.0 seconds
Oct 21 23:04:27 sc-nc ovs-vswitchd: ovs|00021|memory|INFO|handlers:1
ports:1 revalidators:1 rules:4
Oct 21 23:07:17 sc-nc ovs-vsctl: ovs|00001|vsctl|INFO|Called as ovs-vsctl
--no-wait -- --may-exist add-br br-ex
Oct 21 23:07:17 sc-nc ovs-vswitchd: ovs|00022|netdev_linux|WARN|ethtool
command ETHTOOL_GFLAGS on network device br-ex failed: No such device
Oct 21 23:07:17 sc-nc ovs-vswitchd: ovs|00023|dpif|WARN|Dropped 3 log
messages in last 181 seconds (most recently, 181 seconds ago) due to
excessive rate
Oct 21 23:07:17 sc-nc ovs-vswitchd: ovs|00024|dpif|WARN|system at ovs-system:
failed to add br-ex as port: No such device
Oct 21 23:07:17 sc-nc ovs-vswitchd: ovs|00025|bridge|INFO|bridge br-ex:
using datapath ID 00006202e5b3804a
Oct 21 23:07:17 sc-nc ovs-vswitchd: ovs|00026|connmgr|INFO|br-ex: added
service controller "punix:/usr/local/var/run/openvswitch/br-ex.mgmt"

Same command worked some time back on the same system.

On Wed, Oct 21, 2015 at 4:18 PM, Murali R <muralirdev at gmail.com> wrote:

> This is a line from devstack
>
> addbr_cmd=sudo ovs-vsctl --no-wait -- --may-exist add-br br-ex
>
> when it is executed, the br-ex is not always showing up in the system,
> though it does in ovsdb. Please let me know if we can get this working
> consistently with additional settings. I encounter this during unstack  /
> stack cycles.
>
> root at sc-nc:/home/muralir# ovs-vsctl show
> 439d323e-51d0-4bed-92bc-8ee7a89fbd20
>     Bridge br-int
>         fail_mode: secure
>         Port br-int
>             Interface br-int
>                 type: internal
>     Bridge br-ex
>         Port br-ex
>             Interface br-ex
>                 type: internal
>
>
> root at sc-nc:/home/muralir# ip addr
> 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group
> default
>     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
>     inet 127.0.0.1/8 scope host lo
>        valid_lft forever preferred_lft forever
>     inet6 ::1/128 scope host
>        valid_lft forever preferred_lft forever
> .....
> .....(other eth devices attached)...
> ...
> 8: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group
> default
>     link/ether ea:41:7d:55:fc:ce brd ff:ff:ff:ff:ff:ff
> 9: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group
> default
>     link/ether ba:d2:cb:68:8f:42 brd ff:ff:ff:ff:ff:ff
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20151021/9ef2ad5f/attachment-0002.html>


More information about the discuss mailing list