[ovs-discuss] Kernal module problems openvswitch-2.4.0

Pavel Shirshov pavel.shirshov at gmail.com
Thu Oct 22 17:34:55 UTC 2015


Hi Abraam,

Try the following sequence:
1. wget http://openvswitch.org/releases/openvswitch-2.4.0.tar.gz
2. tar xfz openvswitch-2.4.0.tar.gz
3. cd openvswitch-2.4.0
4. DEB_BUILD_OPTIONS='parallel=2 nocheck' fakeroot debian/rules binary
5. cd ..
6. dpkg -i openvswitch-datapath-dkms_2.4.0-1_all.deb
7. dpkg -i openvswitch-common_2.4.0-1_*.deb
8. dpkg -i openvswitch-switch_2.4.0-1_*.deb

P.S.: Put arm_something instead of asterisk. Try to ls to see the file names.

On Wed, Oct 21, 2015 at 5:20 PM, Abraam Athanassios
<abraam.athanassios at gmail.com> wrote:
> Thank you for your help i did follow the file step by step and still not
> getting it.
>
> Also as brief of what i am doing i am trying to install the OVS on Ubuntu
> mate for raspberry pi the previous problems i had that the kernel version
> was not compatible with the older OVS's and at the moment i was trying to
> install the openvswitch-2.4.0.tar.gz.
>
> I am not sure what is wrong with this.
>
> i have kept trying many times and still having the same problem
>
> could this happen because of the raspberry pi limitations (But i don't
> believe so) as i heard that others did install the older versions two years
> ago but i can't get the source files to use it.
>
> On Wed, Oct 14, 2015 at 12:01 PM, Flavio Leitner <fbl at sysclose.org> wrote:
>>
>> On Mon, Oct 12, 2015 at 09:04:38AM -0700, Justin Pettit wrote:
>> >
>> > > On Oct 11, 2015, at 7:07 PM, Abraam Athanassios
>> > > <abraam.athanassios at gmail.com> wrote:
>> > >
>> > > Hi,
>> > >
>> > > I have used the new openvswitch-2.4.0 to install it on raspberry pi 2
>> > > on operating system Ubuntu mate kernal 3.18.
>> > > I am seeking a solution to the problem i am facing.
>> > > I did download the openvswitch and when I do execute the
>> > >
>> > > % sudo make
>> > > % sudo make install
>> > >
>> > > i do not receive any error but when i do execute the
>> > >
>> > > % insmode datapath/linux/openvswitch.ko
>>
>> You need to pass an additional parameter to ./configure script
>> in order to build the datapath module OR you need to use the
>> kernel module provided by your distribution's kernel.
>>
>> See:
>> https://github.com/openvswitch/ovs/blob/master/INSTALL.md
>> and look for "To build the Linux kernel module"
>>
>> fbl
>>
>>
>
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> http://openvswitch.org/mailman/listinfo/discuss
>



More information about the discuss mailing list