[ovs-discuss] ovs dpdk vxlan does NOT work

Chandran, Sugesh sugesh.chandran at intel.com
Wed Sep 23 10:02:39 UTC 2015



Regards
_Sugesh

From: discuss [mailto:discuss-bounces at openvswitch.org] On Behalf Of Pravin Shelar
Sent: Tuesday, September 22, 2015 10:52 PM
To: Na Zhu
Cc: bugs at openvswitch.org
Subject: Re: [ovs-discuss] ovs dpdk vxlan does NOT work



On Mon, Sep 21, 2015 at 10:36 PM, Na Zhu <zhunatuzi at gmail.com<mailto:zhunatuzi at gmail.com>> wrote:
Hi,

I am trying to use ovs dpdk, i follow the README-native-tunneling.md, it does not work.
my setup is:
[内嵌图片 1]
The prefix length of br-vxlan is not 24, is 25, after i create br-vxlan, there is no route in ovs, so i add it by command ovs-appctl.

Which OVS version are you using?

[root at juno ovs-build]# ./bin/ovs-appctl ovs/route/show
Route Table:
Cached: 10.53.87.242/32<http://10.53.87.242/32> dev br-vxlan
Cached: 127.0.0.1/32<http://127.0.0.1/32> dev lo
Cached: 158.85.164.66/32<http://158.85.164.66/32> dev bond1
Cached: 192.168.1.1/32<http://192.168.1.1/32> dev br0
Cached: 158.85.164.64/27<http://158.85.164.64/27> dev bond1
Cached: 192.168.1.0/24<http://192.168.1.0/24> dev br0
Cached: 169.254.0.0/16<http://169.254.0.0/16> dev bond1
Cached: 127.0.0.0/8<http://127.0.0.0/8> dev lo
Cached: 0.0.0.0/0<http://0.0.0.0/0> dev bond1 GW 158.85.164.65
[root at juno ovs-build]#
[root at juno ovs-build]# ./bin/ovs-appctl ovs/route/add 10.53.87.242/25<http://10.53.87.242/25> br-vxlan
OK
[root at juno ovs-build]# ./bin/ovs-appctl ovs/route/show
Route Table:
User: 10.53.87.128/25<http://10.53.87.128/25> dev br-vxlan
Cached: 10.53.87.242/32<http://10.53.87.242/32> dev br-vxlan
Cached: 127.0.0.1/32<http://127.0.0.1/32> dev lo
Cached: 158.85.164.66/32<http://158.85.164.66/32> dev bond1
Cached: 192.168.1.1/32<http://192.168.1.1/32> dev br0
Cached: 158.85.164.64/27<http://158.85.164.64/27> dev bond1
Cached: 192.168.1.0/24<http://192.168.1.0/24> dev br0
Cached: 169.254.0.0/16<http://169.254.0.0/16> dev bond1
Cached: 127.0.0.0/8<http://127.0.0.0/8> dev lo
Cached: 0.0.0.0/0<http://0.0.0.0/0> dev bond1 GW 158.85.164.65
[root at juno ovs-build]#
Then i ping 192.168.1.2, and i capture vxlan packet on eth0 by tcpdump, there is no vxlan packet, do anyone know why?


You can dump-flows from datapath and check what is happening to the packets.
ovs-appctl dpctl/dump-flows

>>>>[Sugesh] My 2 cents
I assume eth0 is DPDK port, in that case you cannot tcpdump on those ports.
Can you please verify the arp entries configured on the OVS ??

ovs-appctl tnl/arp/show

br0 must have the arp entry for “10.53.87.242”
br-vxlan must have the arp entry for “10.53.87.254”

If they are missing you can set them using

ovs-appctl tnl/arp/set br0  10.53.87.242 <MAC address of br-vxlan>
ovs-appctl tnl/arp/set br-vxlan  10.53.87.254 <MAC address of remote end>




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150923/a89e20b4/attachment-0002.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 10395 bytes
Desc: image001.png
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20150923/a89e20b4/attachment-0002.png>


More information about the discuss mailing list