[ovs-discuss] OVS does not start without openvswitch log directory

Gurucharan Shetty shettyg at nicira.com
Fri Sep 25 19:37:29 UTC 2015


On Fri, Sep 25, 2015 at 10:31 AM, Gurucharan Shetty <shettyg at nicira.com> wrote:
> Any reasons to delete the directory? Directories are created during
> package install and not during software start. In this case, wouldn't
> it make more sense to re-create the directory by hand?

I take my above statement back. Looking at
/usr/share/openvswitch/scripts/ovs-lib we do create the logdir before
we start the daemon. In your case, the error at the beginning is only
related to ovs-ctl.log. So one could argue that we should fix the
problem there. But that error should not create problems with starting
ovs-vswitchd or ovsdb-server.


But your error:


start: Job failed to start
2015-09-22T09:27:41Z|00001|daemon_unix|WARN|/var/run/openvswitch/ovs-vswitchd.pid:
open: No such file or directory
ovs-appctl: cannot read pidfile
"/var/run/openvswitch/ovs-vswitchd.pid" (No such file or directory)

It looks unrelated to deleting log file directory to me.

In your second email, you don't seem to have the same error as
reported in the first email. Do you know what changed? Once you start
the service, you should see both ovs-vswitchd and ovsdb-server running
in "ps -ef | grep ovs". You should also see log files in
"/var/log/openvswitch" with the logdir created.

If you don't see the above behavior, can you tell what platform is
this? i.e Ubuntu? Rhel? etc



More information about the discuss mailing list