[ovs-discuss] Bridge does not specify output ; ignoring? (OVS-DPDK Ubuntu)

Ben Pfaff blp at ovn.org
Tue Dec 6 17:37:12 UTC 2016


On Tue, Dec 06, 2016 at 12:20:35PM -0500, Lax Clarke wrote:
> I'm having trouble with 2 OVS bridges I've configured (sitting on top of
> OVS-DPDK):
> 
> 2e18698f-9583-4c59-972c-72c2c32cfc7d
>     Bridge "flat-br-1"
>         Port "stack-1-pts-1-internet-1"
>             Interface "stack-1-pts-1-internet-1"
>                 type: dpdkvhostuser
>         Port "flat-br-1"
>             Interface "flat-br-1"
>                 type: internal
>         Port "dpdk1"
>             Interface "dpdk1"
>                 type: dpdk
>                 options: {n_rxq="2"}
>     Bridge "flat-br-0"
>         Port "flat-br-0"
>             Interface "flat-br-0"
>                 type: internal
>         Port "stack-1-pts-1-subscribers-1"
>             Interface "stack-1-pts-1-subscribers-1"
>                 type: dpdkvhostuser
>         Port "dpdk0"
>             Interface "dpdk0"
>                 type: dpdk
>                 options: {n_rxq="2"}
>     ovs_version: "2.6.0"
> 
> 
> I have these OF rules (nothing special):
> root at terago-2:/home/sandvine/svauto# ovs-ofctl dump-flows flat-br-0
> NXST_FLOW reply (xid=0x4):
>  cookie=0x0, duration=231.086s, table=0, n_packets=9853, n_bytes=591180,
> idle_age=1, priority=0 actions=NORMAL
> root at terago-2:/home/sandvine/svauto# ovs-ofctl dump-flows flat-br-1
> NXST_FLOW reply (xid=0x4):
>  cookie=0x0, duration=234.638s, table=0, n_packets=9984, n_bytes=599040,
> idle_age=2, priority=0 actions=NORMAL
> 
> The traffic is reaching the bridges themselves (i.e., ovs-tcpdump on
> bridges shows the traffic), but not reaching the endpoints (VMs).

OK...

> The error I see in ovs switch log says:
> 2016-12-06T17:14:41.170Z|00092|bridge|ERR|bridge flat-br-0: mirror
> m_flat-br-0 does not specify output; ignoring
> 2016-12-06T17:14:41.170Z|00093|bridge|ERR|bridge flat-br-0: mirror
> m_flat-br-0 does not specify output; ignoring
> 2016-12-06T17:14:41.170Z|00094|bridge|ERR|bridge flat-br-0: mirror
> m_flat-br-0 does not specify output; ignoring
> 2016-12-06T17:14:41.171Z|00095|bridge|ERR|bridge flat-br-1: mirror
> m_flat-br-1 does not specify output; ignoring
> 2016-12-06T17:14:41.171Z|00096|bridge|ERR|bridge flat-br-1: mirror
> m_flat-br-1 does not specify output; ignoring
> 2016-12-06T17:14:41.171Z|00097|bridge|ERR|bridge flat-br-1: mirror
> m_flat-br-1 does not specify output; ignoring
> 
> What does this mean?
> I browsed code here
> https://github.com/osrg/openvswitch/blob/master/vswitchd/bridge.c#L3641
> It seems to suggest that I need either an output port or an output vlan.

How did you configure mirroring?


More information about the discuss mailing list