[ovs-discuss] ovs-appctl route add issue to different subnet

SIVA KUMAR G sivakumar.gangarapu at gmail.com
Tue Dec 13 03:36:00 UTC 2016


Hi,

Im trying to add a route to a different subnet from br-eth1.

As shown below br-eth1 belongs 172.x.x.x. My requirement is to create
a static route to different

Subnet say 173.x.x.x with br-eth1 as nexthop.


When i try to add route using ovs-appctl, im getting an error "Error
while inserting the route"


I tried enable debug logs for all modules couldn't find any more
detail than the above error message.

Could you please let me know jow to resolve it ?

I created alias ip for br-eth1 under 173.x.x.x, as a temporary
resolve. Is it possible to create a route to a different without alias
ip?




                 192.168.1.1/24
                +--------------+
                |    int-br    |
192.168.1.2/24
                +--------------+
+--------------+
                |    vxlan0    |                                   |
 vxlan0    |
                +--------------+
+--------------+
                       |                                                  |
                       |                                                  |
                       |                                                  |
                 173.168.1.1/24                                           |
                +--------------+                                          |
                |    br-eth1   |
172.168.1.2/24
                +--------------+
+---------------+
                |    eth1      |----------------------------------|
  eth1     |
                +--------------+
+---------------+

Thanks,
Siva
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20161213/9f003c2c/attachment-0001.html>


More information about the discuss mailing list