[ovs-discuss] [dpdk-dev] DPDK with vhostuser - Issue in Testing with DPDK-Pktgen

Abhijeet Karve abhijeet.karve at tcs.com
Fri Feb 26 18:23:43 UTC 2016


Dear keith,

we do not have any idea on how to troubleshoot it further.

Kindly suggest us something on this regard if we need to tune anything on 
Openstack end or in pktgen application. 

Thanks & Regards
Abhijeet Karve

 -----"Wiles, Keith" <keith.wiles at intel.com> wrote: -----

 =======================
 To: Abhijeet Karve <abhijeet.karve at tcs.com>, "Czesnowicz, Przemyslaw" <przemyslaw.czesnowicz at intel.com>, "Mooney, Sean K" <sean.k.mooney at intel.com>, "Chandran, Sugesh" <sugesh.chandran at intel.com>
 From: "Wiles, Keith" <keith.wiles at intel.com>
 Date: 02/26/2016 11:13PM 
 Cc: "discuss at openvswitch.org" <discuss at openvswitch.org>
 Subject: Re: [dpdk-dev] DPDK with vhostuser - Issue in Testing with DPDK-Pktgen
 =======================
   >Dear Przemek, Sean & Sugesh,
>
>It would be great if get your valuable inputs for the below listed issue. 
>We have setup DPDK with vhostuser in AllinOne setup on following software 
>platform.
>_____________
>Openstack: Kilo
>Distribution: Ubuntu 14.04
>OVS Version: 2.4.0
>DPDK 2.0.0
>_____________
>
>In our Openstack OVS-DPDK  set up, we are spawning 2 instance on same host 
>with Ubuntu and running DPDK-pktgen in one of the VM and measuring traffic 
>between VMs of same host.
>
>VMs spec are 8GB of memory and 4 core, we are using one port for pktgen 
>application.
> 
>Please fine the VM huge page setting as well,
> 
>HugePages_Total:    1024
>HugePages_Free:      896
>HugePages_Rsvd:        0
>HugePages_Surp:        0
>Hugepagesize:       2048 kB
> 
>Please find the below command we are using,
> 
>./app/app/$RTE_TARGET/pktgen -c 0f -n 3  --proc-type auto --socket-mem 256 
>-b 0000:00:03.0 -- -P -m "[1-3].0"
> 
>Regardless of the cores whatever we are passing here(-m "[1-3].0"), the 
>traffic is sending via only one core, remaining 2 cores are idle.

I verified on my machine in the host userspace that all three lcores were sending packets. Could it be something with the VM not scheduling the other cores for some reason?

> 
>We have added specific property as well to the images we are using,
> 
>hw:­vif_multiqueue_­enabled=­true à Flavor property
>hw_­vif_mutliqueue_­enabled=­true à Image property
> 
>Still we got the same issue on the application.
> 
>From logs,
>. . . . .
>** Dev Info (rte_virtio_pmd:0) **
>   max_vfs        :   0 min_rx_bufsize    :  64 max_rx_pktlen :  9728 
>max_rx_queues         :   1 max_tx_queues:   1
>. . . . .
> 
>
>Kindly suggest us something on this regard if we need to tune anything on 
>Openstack end or in pktgen application.
>
>
>Thanks & Regards
>Abhijeet Karve
>=====-----=====-----=====
>Notice: The information contained in this e-mail
>message and/or attachments to it may contain 
>confidential or privileged information. If you are 
>not the intended recipient, any dissemination, use, 
>review, distribution, printing or copying of the 
>information contained in this e-mail message 
>and/or attachments to it are strictly prohibited. If 
>you have received this communication in error, 
>please notify us by reply e-mail or telephone and 
>immediately and permanently delete the message 
>and any attachments. Thank you
>
>
>


Regards,
Keith




    



More information about the discuss mailing list