[ovs-discuss] OVS Multicast Issues version 2.4/2.5

Dominick Krachtus (TT) dominick.krachtus at tradingtechnologies.com
Wed Jun 22 18:37:55 UTC 2016


Today I have built ovs from branch-2.5 which is version 2.5.1 according to
ovs-vsctl -V. This version has solved all issues that we are seeing with
multicast. There is no longer flooding into other VMs and the OVS MCAST
table is properly being updated when IGMP reports are sent out.

ovs-vsctl (Open vSwitch) 2.5.1

Compiled Jun 22 2016 12:26:40

DB Schema 7.12.1



On Mon, May 9, 2016, 19:21 Ben Pfaff <blp at ovn.org> wrote:

> On Thu, May 05, 2016 at 02:39:34PM +0000, Dominick Krachtus (TT) wrote:
> > Below are the steps i have taken to setup our current testing
> environment.
> > As of now this environment is up and functioning with multicast working.
> > There are however some oddities with multicast. Testing with omping
> > produces miked results while using our application works without issues.
> So
> > far I have tried four different ways of configuring the environment and
> the
> > current config  has been working the best.
> >
> > I have upgraded the OVS to 2.5 and saw that it fixed a majority of the
> > ompoing issues but not the MCAST state table aging issue is still
> present.
> > This appears to be some type of possible bug with the IGMP snooping
> > implementation within the OVS.
>
> I've recently posted a couple of patches for IGMP issues.  Please try
> them and see whether they fix the problems you are seeing.
>
> Patch 1: https://patchwork.ozlabs.org/patch/619681/
> Patch 2: http://openvswitch.org/pipermail/discuss/2016-May/021234.html
>
> Thanks,
>
> Ben.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/discuss/attachments/20160622/8fee4d7a/attachment-0001.html>


More information about the discuss mailing list