[ovs-discuss] Setting a VLAN ID

Elisa Rojas elisa.rojas.sanchez at gmail.com
Fri Jun 3 16:17:21 UTC 2016


Thank you Ben,

We changed the order from:
actions=output:1,mod_vlan_vid:1

To:
actions=mod_vlan_vid:1,output:1

For both rules, but we still have the same behaviour... It's a pity because
I had the hope that would solve it!
Maybe the actions should be still different?

What I see now is one match. I'm copying the log again:

mininet> h1 arp -s 10.0.0.3 00:00:00:00:00:03
mininet> h3 arp -s 10.0.0.1 00:00:00:00:00:01
mininet> h1 ping -c 1 h3
PING 10.0.0.3 (10.0.0.3) 56(84) bytes of data.

--- 10.0.0.3 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

mininet> h1 ping -c 1 h3
PING 10.0.0.3 (10.0.0.3) 56(84) bytes of data.

--- 10.0.0.3 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

mininet> dpctl dump-flows
*** s1
------------------------------------------------------------------------
NXST_FLOW reply (xid=0x4):
 cookie=0x10000487f63a1, duration=74.815s, table=0, n_packets=0, n_bytes=0,
idle_age=74, priority=40000,dl_type=0x8942 actions=CONTROLLER:65535
 cookie=0x10000487f5557, duration=74.813s, table=0, n_packets=0, n_bytes=0,
idle_age=74, priority=40000,dl_type=0x88cc actions=CONTROLLER:65535
 cookie=0x10000488ebd5d, duration=74.778s, table=0, n_packets=0, n_bytes=0,
idle_age=74, priority=40000,arp actions=CONTROLLER:65535
 cookie=0x1000046444328, duration=51.847s, table=0, n_packets=1,
n_bytes=102, idle_age=37, priority=5,ip actions=CONTROLLER:65535
 cookie=0x4c00000e827191, duration=37.764s, table=0, n_packets=0,
n_bytes=0, idle_age=37,
priority=500,ip,in_port=3,dl_vlan=305,nw_dst=10.0.0.1
actions=mod_vlan_vid:1,output:1
 cookie=0x4c00000e8248c2, duration=37.763s, table=0, n_packets=1,
n_bytes=102, idle_age=21,
priority=500,ip,in_port=1,dl_vlan=1,nw_src=10.0.0.1
actions=mod_vlan_vid:305,output:3
mininet> h1 ping -c 1 h3
PING 10.0.0.3 (10.0.0.3) 56(84) bytes of data.
^C
--- 10.0.0.3 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms


Thank you!!

2016-06-03 18:02 GMT+02:00 Ben Pfaff <blp at ovn.org>:

> On Fri, Jun 03, 2016 at 05:47:46PM +0200, Elisa Rojas wrote:
> > n_bytes=0, idle_age=17,
> > priority=500,ip,in_port=3,dl_vlan=305,nw_dst=10.0.0.1
> > actions=output:1,mod_vlan_vid:1
>
> Modifying a packet after you output it will have no visible effect.
> Instead, modify it before you output it.
>



-- 
*Elisa Rojas Sánchez*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20160603/a76414a0/attachment-0002.html>


More information about the discuss mailing list