[ovs-discuss] changing path for startup

Rajasekaran, Monica Monica.Rajasekaran at us.fujitsu.com
Wed Jun 22 16:17:38 UTC 2016


Hi,

I built ovs along with Yocto, have it running inside my target hardware.

When I start ovs by starting ovsdb server, vsctl and vswitchd, it gives me the following error messages:

When I start ovsdb server,

2016-06-22T23:54:25Z|00001|fatal_signal|WARN|could not unlink "/usr/local/var/run/openvswitch/db.sock" (No such file or directory)
2016-06-22T23:54:25Z|00002|stream_unix|ERR|/usr/local/var/run/openvswitch/db.sock: binding failed: No such file or directory
2016-06-22T23:54:25Z|00003|ovsdb_jsonrpc_server|ERR|punix:/usr/local/var/run/openvswitch/db.sock: listen failed: No such file or directory

When I start vsctl,

2016-06-22T23:54:50Z|00003|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)

When I start vswitchd,

2016-06-22T23:55:14Z|00003|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)

The problem is that it is looking for db.sock and the pid files at "/usr/local/var/run/openvswitch" but actually it should be looking into "/var/run/openvswitch" in Yocto. How do I change this ?? Or will creating a symlink work?

Thanks,
Monica

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20160622/9ae26c1b/attachment-0002.html>


More information about the discuss mailing list