[ovs-discuss] pci_map_resource(): cannot mmap(..): Invalid argument (0xffffffffffffffff)

Fischetti, Antonio antonio.fischetti at intel.com
Tue Jun 28 07:39:31 UTC 2016

Hi Charlie,
while this issue is happening with Fed23 can you check what are the 2 outputs of

1.       sudo $DPDK_DIR/tools/dpdk_nic_bind.py --status

and also

2.       lspci | grep 02:00



From: discuss [mailto:discuss-bounces at openvswitch.org] On Behalf Of Charlie Li
Sent: Friday, June 24, 2016 4:36 PM
To: discuss at openvswitch.org
Subject: [ovs-discuss] pci_map_resource(): cannot mmap(..): Invalid argument (0xffffffffffffffff)


I am trying to set up openvswitch-2.5.0 with DPDK-2.2.0 by following "INSTALL.DPDK.md<http://INSTALL.DPDK.md>".

First tried with Ubuntu server 16.04 and it worked as expected.

But when tried with Fedora server 23, it hit the following error

EAL: pci_map_resource(): cannot mmap(10, 0x7f1800000000, 0x80000, 0x0): Invalid argument (0xffffffffffffffff)

when invoking

sudo ./ovs-vswitchd --dpdk -c 0x1 -n 4 -- unix:$DB_SOCK --pidfile --detach

I tested it on the same hardware platform and followed the same instructions. Why it only failed with Fedora?

I am also attaching the detailed logs from both Ubuntu (working case) and Fedora (failing case).

Any help is appreciated.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://openvswitch.org/pipermail/ovs-discuss/attachments/20160628/6daabe3c/attachment-0002.html>

More information about the discuss mailing list