[ovs-discuss] ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)

O'Reilly, Darragh darragh.oreilly at hpe.com
Thu Nov 17 14:09:07 UTC 2016


Maybe you need to generate the links with update-rc.d
 http://www.tin.org/bin/man.cgi?section=8&topic=update-rc.d


From: Ashish Kurian [mailto:ashishbnv at gmail.com] 
Sent: 17 November 2016 13:38
To: O'Reilly, Darragh <darragh.oreilly at hpe.com>
Cc: discuss at openvswitch.org
Subject: Re: [ovs-discuss] ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)

Dear Darragh,
I do not think it is symlinked. And I do not have any file with *switch* in etc/rc3.d


Best Regards,
Ashish Kurian

On Thu, Nov 17, 2016 at 2:31 PM, O'Reilly, Darragh <darragh.oreilly at hpe.com> wrote:
Is it symlinked to like:
 
$ ls -l /etc/rc3.d/*switch*
lrwxrwxrwx 1 root root 28 Aug  3 17:06 /etc/rc3.d/S03openvswitch-switch -> ../init.d/openvswitch-switch
 
 
From: ovs-discuss-bounces at openvswitch.org [mailto:ovs-discuss-bounces at openvswitch.org] On Behalf Of Ashish Kurian
Sent: 17 November 2016 13:14
To: discuss at openvswitch.org
Subject: [ovs-discuss] ovs-vsctl: unix:/var/run/openvswitch/db.sock: database connection failed (No such file or directory)
 
Dear Members,
I have installed and tested OVS. But after reboot, I get the error in the subject when I run the commands - sudo ovs-vsctl show
I have already added the openvswitch-switch.init to the directory /etc.init.d/openvswitch-switch but it is not getting executed on start up
If I run the commands manually by sudo /etc/init.d/openvswitch-switch start , everything works fine. Please help me with this issue if any one is aware of a fix


Best Regards,
Ashish Kurian



More information about the discuss mailing list