[ovs-discuss] getting build errors while building ovs2.7.0

Joe Stringer joe at ovn.org
Mon Aug 14 17:48:05 UTC 2017


On 11 August 2017 at 11:52, Prem Shankar Sharma via discuss
<ovs-discuss at openvswitch.org> wrote:
> Hi,
> I'm getting some build errors while trying to build ovs2.7.0 on redhat 7.2.
> I cloned 2.7.0 from git and tried to run - make and make modules_install (to
> build kernel module). The output of both of them is reporting some issues
> like:

Hi Prem,

The kernel module that comes with OVS 2.7.0 doesn't support Redhat 7.2
- RHEL7.2 is newer than OVS 2.7. You can use the module that is
distributed with RHEL (and not compile the version from OVS tree), or
wait for the upcoming OVS 2.8 release that is expected later this
month. Alternatively if you are happy running on the master version of
OVS, you might consider just cloning and building the top of tree from
github.

Cheers,
Joe


More information about the discuss mailing list