[ovs-discuss] problem with openvswitch 2.5.2 after upgrade to Ubuntu 16.04

Chad Willman cwillman at ixiacom.com
Wed Aug 23 17:19:52 UTC 2017


Hi,

I eliminated the lxcbr0, but still have the same problem with ovs-vswitchd eating CPU.


cwillman at harley:~$ sudo brctl show

bridge name bridge id STP enabled interfaces

ovsbr0 8000.c6074be69e43 no em1

vnet0

vnet1

vnet2


kern.log is also flooding with this message - Aug 23 07:36:03 harley NetworkManager[2481]: <info>  [1503491763.8976] device (ovsbr0): enslaved to non-master-type device ovs-system; ignoring

Aug 23 07:36:03 harley kernel: [58455.254778] device ovsbr0 entered promiscuous mode

Aug 23 07:36:03 harley kernel: [58455.257975] device ovsbr0 left promiscuous mode


Would appreciate any other suggestions.


Regards,


Chad


From: Chad W <cwillman at ixiacom.com<mailto:cwillman at ixiacom.com>>
Date: Wednesday, August 23, 2017 at 11:55 AM
To: Ben Warren <ben at skyportsystems.com<mailto:ben at skyportsystems.com>>
Cc: "ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>" <ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>>
Subject: Re: [ovs-discuss] problem with openvswitch 2.5.2 after upgrade to Ubuntu 16.04

Hi Ben and thanks for the response.

brctl shows me this -

bridge namebridge id STP enabledinterfaces

lxcbr08000.00163e000000 no

ovsbr08000.c6074be69e43 no em1

vnet0

vnet1

vnet2


The ovsbr0 bridge looks right, but the lxcbr0 should not be there.

Not sure how it got there (we have multiple admins on this system), but I’ll try nuking it.


Regards,


Chad


From: Ben Warren <ben at skyportsystems.com<mailto:ben at skyportsystems.com>>
Date: Wednesday, August 23, 2017 at 11:43 AM
To: Chad W <cwillman at ixiacom.com<mailto:cwillman at ixiacom.com>>
Cc: "ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>" <ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>>
Subject: Re: [ovs-discuss] problem with openvswitch 2.5.2 after upgrade to Ubuntu 16.04

Hi Chad,

I’ve seen this if regular Linux bridging is enabled.  The command ‘brctl show’ will display non-OVS bridges.

regards,
Ben

On Aug 23, 2017, at 9:23 AM, Chad Willman <cwillman at ixiacom.com<mailto:cwillman at ixiacom.com>> wrote:


Is there a forum specific to discing issues encountered ?

My ovs-vswitchd daemon is consuming 400% CPU and flooding ovs-vswitchd.log with the same message repeatedly - 2017-08-23T16:18:28.049Z|641473|bridge|INFO|bridge ovsbr0: added interface ovsbr0 on port 65534

Looking for help or ideas for debugging the issue.

Thanks,

CW
_______________________________________________
discuss mailing list
discuss at openvswitch.org<mailto:discuss at openvswitch.org>
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20170823/b85f46f2/attachment-0001.html>


More information about the discuss mailing list