[ovs-discuss] systemd issue

Muminul Islam Russell misla011 at fiu.edu
Fri Jan 20 23:08:39 UTC 2017


Hi,

I am using 2.3.1 version and having issue with starting openvswitch
service with systemd.

[root at localhost ~]# systemctl status openvswitch

Jan 20 15:00:54 localhost systemd[1]: Starting LSB: Open vSwitch switch...
Jan 20 15:00:54 localhost openvswitch[3196]: Starting ovsdb-server
ovsdb-server: /var/run/openvswitch/ovsdb-server.pid: pidfile check
failed (Permission denied), aborting
Jan 20 15:00:54 localhost openvswitch[3196]: [FAILED]
Jan 20 15:00:54 localhost openvswitch[3196]: ovs-vsctl:
unix:/var/run/openvswitch/db.sock: database connection failed
(Permission denied)
Jan 20 15:00:54 localhost openvswitch[3196]: Starting ovs-vswitchd
ovs-vswitchd: /var/run/openvswitch/ovs-vswitchd.pid: pidfile check
failed (Permission denied), aborting
Jan 20 15:00:54 localhost openvswitch[3196]: [FAILED]
Jan 20 15:00:54 localhost openvswitch[3196]: Enabling remote OVSDB
managers 2017-01-20T23:00:54Z|00001|daemon_unix|WARN|/var/run/openvswitch/ovsdb-server.pid:
open: Permission denied
Jan 20 15:00:54 localhost openvswitch[3196]: ovs-appctl: cannot read
pidfile "/var/run/openvswitch/ovsdb-server.pid" (Permission denied)
Jan 20 15:00:54 localhost openvswitch[3196]: [FAILED]
Jan 20 15:00:54 localhost systemd[1]: Started LSB: Open vSwitch switch.

P.S: selinux mode is enforcing.

Could anyone tell me what is wrong  here?

Thanks,
Muminul


More information about the discuss mailing list