[ovs-discuss] systemd issue

Ansis Atteka aatteka at nicira.com
Mon Jan 23 18:46:35 UTC 2017


On Fri, Jan 20, 2017 at 3:48 PM, Muminul Islam Russell <misla011 at fiu.edu> wrote:
> Thanks for the clarification.
>
> When I change selinux mode to permissive it goes through. I am
> wondering if there is a way
> to resolve this issue while selinux in enforcing mode.

This could be something as trivial as:
1. deleting /var/run/openvswitch directory and/or all its contents
that were properly taggerd with one of openvswitch type
2. manually recreating this directory under wrong unconfined type.


Can you post output of `ls -Z`  command for /var/run/openvswitch
directory and also all its contents to provide or disprove the theory
I have above?

>
> Thanks,
> Muminul
>
> On Fri, Jan 20, 2017 at 3:35 PM, Ben Pfaff <blp at ovn.org> wrote:
>> On Fri, Jan 20, 2017 at 03:08:39PM -0800, Muminul Islam Russell wrote:
>>> Hi,
>>>
>>> I am using 2.3.1 version and having issue with starting openvswitch
>>> service with systemd.
>>>
>>> [root at localhost ~]# systemctl status openvswitch
>>>
>>> Jan 20 15:00:54 localhost systemd[1]: Starting LSB: Open vSwitch switch...
>>> Jan 20 15:00:54 localhost openvswitch[3196]: Starting ovsdb-server
>>> ovsdb-server: /var/run/openvswitch/ovsdb-server.pid: pidfile check
>>> failed (Permission denied), aborting
>>
>> ovsdb-server tried to check whether it was already running, by reading
>> its own pidfile, but it couldn't read it due to a "permission denied"
>> error.
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-discuss


More information about the discuss mailing list