[ovs-discuss] Branch 2.3 build failure

Shu Shen shu.shen at gmail.com
Thu Jan 26 23:01:21 UTC 2017


Hi Ben,

Building on branch 2.3 appears to be failing with the following error:

    lib/lacp.c:620:9: error: mixing declarations and code
    make[2]: *** [lib/lacp.lo] Error 1

This appears to be caused by commit 336a5584df931 and the fact that
-Wdeclaration-after-statement is enabled on Branch 2.3 in configure.ac
while the flag is disabled on 2.4 branch and later.

I'm not sure how to submit a patch for a maintenance branch so I'd like
to bring this to your attention.

/Shu


More information about the discuss mailing list