[ovs-discuss] error: "Error attaching device '0000:83:00.0' to DPDK"

Chandran, Sugesh sugesh.chandran at intel.com
Wed Jul 12 15:16:03 UTC 2017



Regards
_Sugesh

From: ovs-discuss-bounces at openvswitch.org [mailto:ovs-discuss-bounces at openvswitch.org] On Behalf Of lvzhilong at ncic.ac.cn
Sent: Wednesday, July 12, 2017 10:31 AM
To: ovs-discuss <ovs-discuss at openvswitch.org>
Subject: [ovs-discuss] error: "Error attaching device '0000:83:00.0' to DPDK"


Hello,

I have installed OVS 2.7 running.  When I do:

# ovs-vsctl add-port br0 dpdk-p0 -- set Interface dpdk-p0

type=dpdk options:dpdk-devargs=0000:82:00.0

ovs-vsctl: Error detected while setting up 'dpdk-p0': Error attaching

device '0000:82:00.0' to DPDK.  See ovs-vswitchd log for details.



here is some informations:
1.    root at oncsg4:/var/log/openvswitch# $DPDK_DIR/tools/dpdk-devbind.py --status

Network devices using DPDK-compatible driver
============================================
0000:83:00.0 'Ethernet 10G 2P X710 Adapter' drv=vfio-pci unused=uio_pci_generic
0000:83:00.1 'Ethernet 10G 2P X710 Adapter' drv=uio_pci_generic unused=vfio-pci




2. the log file shows:

      (1).    2017-07-07T10:04:40.004Z|00064|netdev_dpdk|WARN|Error attaching device '0000:82:00.0' to DPDK

      (2).    2017-07-07T10:04:40.004Z|00065|netdev|WARN|dpdk-p0: could not set configuration (Invalid argument)

[Sugesh] Shouldn’t be this '0000:83:00.0' instead of '0000:82:00.0'

________________________________
lvzhilong at ncic.ac.cn<mailto:lvzhilong at ncic.ac.cn>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20170712/9c18c37f/attachment.html>


More information about the discuss mailing list