[ovs-discuss] OVS-DPDK - af_packet vdev configuration - Error

Avi Cohen (A) avi.cohen at huawei.com
Sun Jun 18 14:44:50 UTC 2017


I  made  upgrade to ovs2.7.0  and dpdk17.02.1
And got  these error msgs  when I run 
     ovs-vsctl add-port br0 tap1 -- set Interface tap1 type=dpdk \
      options:dpdk-devargs=eth_af_packet0,iface=tap1

Jun 18 14:36:29 ip-172-31-100-80 ovs-vswitchd[54914]: ovs|00047|netdev_dpdk|INFO|Device 'eth_af_packet0,iface=tap1' attached to DPDK

Jun 18 14:36:29 ip-172-31-100-80 ovs-vswitchd[54914]: ovs|00050|netdev_dpdk|WARN|Interface tap1 eth_dev setup error Invalid argument

Jun 18 14:36:29 ip-172-31-100-80 ovs-vswitchd[54914]: ovs|00051|netdev_dpdk|ERR|Interface tap1(rxq:1 txq:1) configure error: Invalid argument

Jun 18 14:36:29 ip-172-31-100-80 ovs-vswitchd[54914]: ovs|00052|dpif_netdev|ERR|Failed to set interface tap1 new configuration

Jun 18 14:36:29 ip-172-31-100-80 ovs-vswitchd[54914]: ovs|00053|bridge|WARN|could not add network device tap1 to ofproto (No such device)

Can someone tell what is wrong with my cli command ?
Best Regards
avi

> -----Original Message-----
> From: Avi Cohen (A)
> Sent: Sunday, 18 June, 2017 1:59 PM
> To: ovs-discuss at openvswitch.org; users at dpdk.org
> Subject: OVS-DPDK - af_packet vdev configuration - Error
> 
> Hi All,
> 
> I have ovs 2.6.1 with dpdk-stable-16.07.2 ,  I'm trying to create  an af_packet
> vdev interface with the following commands:
> 
>     1.    ip tuntap add dev tap1 mode tap
> 
>    2.    ovs-vsctl add-port br0 tap1 -- set Interface tap1 type=dpdk \
>       options:dpdk-devargs=eth_af_packet0,iface=tap1
> 
> but I get an error message [could not open network device tap1 - No such
> device ]
> 
> can you assist  how to set this interface ?
> 
> Best Regards
> avi


More information about the discuss mailing list