[ovs-discuss] load:OXM_OF_ETH_DST[25..32]->NXM_NX_REG0[0..7] problem

Ali Volkan Atli Volkan.Atli at argela.com.tr
Fri May 12 19:12:32 UTC 2017


I am trying to implement a simple fat-tree topology using the two-level routing tables what is written in the paper (A Scalable, Commodity Data Center Network Architecture). Briefly it tries to use prefix and suffix concepts as below

table=0,   -> Output: 1
table=0,   -> Output: 2
table=0,    -> goto_table: 1

table=1,     -> Output: 3
table=1,     -> Output: 4

I know OvS does not have suffix, so I tried to load the last digit of ip into reg0, then use it in table1 but it did not work


when I tried to ping from to, the following entries are shown in dump-flows. Always "load:0", but it must have been load:2

 cookie=0x0, duration=4.640s, table=0, n_packets=0, n_bytes=0, idle_age=4, dl_type=0x88cc actions=CONTROLLER:65535
 cookie=0x0, duration=4.363s, table=0, n_packets=3, n_bytes=294, idle_age=1, priority=0,ip actions=load:0->NXM_NX_REG0[0..7],resubmit(,1)
 cookie=0x0, duration=4.378s, table=0, n_packets=0, n_bytes=0, idle_age=4, ip,nw_dst= actions=output:3
 cookie=0x0, duration=4.371s, table=0, n_packets=0, n_bytes=0, idle_age=4, ip,nw_dst= actions=output:4
 cookie=0x0, duration=4.356s, table=1, n_packets=0, n_bytes=0, idle_age=4, reg0=0x2 actions=output:1
 cookie=0x0, duration=4.349s, table=1, n_packets=0, n_bytes=0, idle_age=4, reg0=0x3 actions=output:2

Thanks in advance

- Volkan

More information about the discuss mailing list