[ovs-discuss] OVS bridge on boot in Debian

Omar Ramadan oramadan at fb.com
Tue Oct 17 21:17:37 UTC 2017


Hey Guru,


I am trying to get the NetworkManager to bring up my gtp-vport using /etc/network/interfaces.d/br0 but it isn't getting added. This is my config:


allow-ovs br0

iface br0 inet dhcp

    ovs_type OVSBridge

    ovs_ports eth0 gre0 gtp0


allow-br0 eth0

iface eth0 inet manual

    ovs_bridge br0

    ovs_type OVSPort


allow-br0 gre0

iface gre0 inet manual

    ovs_bridge br0

    ovs_type OVSTunnel

    ovs_tunnel_type gre

    ovs_tunnel_options options:remote_ip=182.168.60.141 options:key=1


allow-br0 gtp0

iface gtp inet manual

    ovs_bridge br0

    ovs_type OVSTunnel

    ovs_tunnel_type gtp

    ovs_tunnel_options options:remote_ip=flow options:key=flow

So the bridge is set up, and eth0 and gre0 are added. The gtp0 device is not and there don't seem to be any errors mentioning gtp-vport that I can find. I can also add the gtp-vport manually without issues:


ovs-vsctl add-port br0 gtp-vport -- set interface gtp-vport ofport_request=4 type=gtp option:remote_ip=flow options:key=flow

Do I need to register new a ovs_tunnel_type somewhere for it to work? Any way to increase logging here?

Best,
Omar

________________________________
From: Guru Shetty <guru at ovn.org>
Sent: Friday, October 13, 2017 10:46 AM
To: Omar Ramadan
Cc: ovs-discuss at openvswitch.org
Subject: Re: [ovs-discuss] OVS bridge on boot in Debian



On 12 October 2017 at 16:54, Omar Ramadan <oramadan at fb.com<mailto:oramadan at fb.com>> wrote:

A related question: What is the best way to configure a set of controllers? Can I specify a set of controllers for my bridge to use in a similar fashion in networking?

The detailed documentation is here:
https://github.com/openvswitch/ovs/blob/master/debian/openvswitch-switch.README.Debian

You can in effect do anything you want via the "ovs_extra" option. It takes ovs-vsctl's datatabase manupulation commands.
e.g:
ovs_extra add-port br0 p1 -- set-manager ptcp:3332:192.168.1.2 -- blah


________________________________
From: ovs-discuss-bounces at openvswitch.org<mailto:ovs-discuss-bounces at openvswitch.org> <ovs-discuss-bounces at openvswitch.org<mailto:ovs-discuss-bounces at openvswitch.org>> on behalf of Omar Ramadan <oramadan at fb.com<mailto:oramadan at fb.com>>
Sent: Thursday, October 12, 2017 4:47:10 PM

To: Guru Shetty
Cc: ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>
Subject: [Potential Spoof] Re: [ovs-discuss] OVS bridge on boot in Debian


Looks like I was missing the kernel module. Added "openvswitch-datapath-dkms" and it works now.


Thanks!

________________________________
From: ovs-discuss-bounces at openvswitch.org<mailto:ovs-discuss-bounces at openvswitch.org> <ovs-discuss-bounces at openvswitch.org<mailto:ovs-discuss-bounces at openvswitch.org>> on behalf of Omar Ramadan <oramadan at fb.com<mailto:oramadan at fb.com>>
Sent: Thursday, October 12, 2017 4:31:24 PM
To: Guru Shetty
Cc: ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>
Subject: [Potential Spoof] Re: [ovs-discuss] OVS bridge on boot in Debian


Hi Guru, Ben,


Thanks for the responses. I originally did a "make install" though I realized there may be some packaging postinst scripts that may need to be run for it to work. I built and installed openvswitch-common and openvswitch-switch.


"ifup --allow=ovs br0" still fails to find br0 but I've made progress nonetheless in the networking journal

vagrant at magma-dev:/etc/network$ sudo journalctl -u networking
Oct 12 23:27:29 magma-dev ovs-vsctl[2127]: ovs|00001|vsctl|INFO|Called as ovs-vsctl --timeout=5 -- --may-exist add-port br0 eth0 --
Oct 12 23:27:29 magma-dev networking[1875]: ovs-vsctl: Error detected while setting up 'eth0'.  See ovs-vswitchd log for details.
Oct 12 23:27:29 magma-dev networking[1875]: ovs-vsctl: The default log directory is "/var/log/openvswitch".
Oct 12 23:27:29 magma-dev ovs-vsctl[2202]: ovs|00001|vsctl|INFO|Called as ovs-vsctl --timeout=5 -- --may-exist add-port br0 eth0 --

vagrant at magma-dev:/var/log/openvswitch$ sudo less ovs-vswitchd.log
2017-10-12T23:27:31.123Z|00112|ofproto|ERR|failed to open datapath br0: No such file or directory
2017-10-12T23:27:31.123Z|00113|bridge|ERR|failed to create bridge br0: No such file or directory

What could be missing?

Best,
Omar


________________________________
From: Guru Shetty <guru at ovn.org<mailto:guru at ovn.org>>
Sent: Thursday, October 12, 2017 10:50:38 AM
To: Omar Ramadan
Cc: ovs-discuss at openvswitch.org<mailto:ovs-discuss at openvswitch.org>
Subject: Re: [ovs-discuss] OVS bridge on boot in Debian



On 12 October 2017 at 10:29, Omar Ramadan <oramadan at fb.com<mailto:oramadan at fb.com>> wrote:

Hi list,


I am using OVS 2.7.90 with Debian 8.7 and want to configure the switch to be loaded on system initialization. I have installed the service "openvswitch-switch" and added the following in /etc/network/interfaces

How did you install OVS 2.7.90? By 'make install' or via debian packages?



allow-ovs br0

iface br0 inet dhcp

    ovs_type OVSBridge

    ovs_ports eth0


allow-br0 eth0

iface eth0 inet manual

    ovs_bridge br0

    ovs_type OVSPort

I am still unable to load br0 with ifup.


vagrant at magma-dev:/etc/network/interfaces.d$ sudo ifup br0
Lets try with:
ifup --allow=ovs br0



Cannot find device "br0"

Bind socket to interface: No such device


exiting.

Failed to bring up br0.

How do these interfaces get set up? Is there anyway to debug this? I've built this package from source, so I want to make sure I am not missing dependencies. Also should I be adding any additional systemctl units or should adding "openvswitch-switch" be enough?

Best,
Omar

_______________________________________________
discuss mailing list
discuss at openvswitch.org<mailto:discuss at openvswitch.org>
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss<https://urldefense.proofpoint.com/v2/url?u=https-3A__mail.openvswitch.org_mailman_listinfo_ovs-2Ddiscuss&d=DwMFaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=07s_Z0lQVjg7gmpzZt5Yog&m=cIvIKPE2b3yN4d3z9aOIwbQM0etdwuEs_AYVr7Q2Clo&s=-hNIrnwJO4HaR86DPjqOcRpQS_6pBzteYzzhFAFf3yU&e=>



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20171017/7a360978/attachment-0001.html>


More information about the discuss mailing list