[ovs-discuss] error with openvswitch (dpif(handler2)|WARN|system at ovs-system: failed to put[create] (Invalid argument) ufid:)

Aaron Conole aconole at redhat.com
Wed Oct 18 20:38:01 UTC 2017


Hi Jean,

Jean Hsiao <jhsiao at redhat.com> writes:

> While running PvP RFC2544 testing over geneve tunnel, we're getting this WARN message:
>
> 017-10-02T17:25:04.051Z|00001|dpif(revalidator25)|WARN|netdev at ovs-netdev: failed to put
> [modify] (No such file or directory) ufid:78499e82-1c5d-49ac-8cc1-7b26ab733be6 skb_priority
> (0/0),tunnel
> (tun_id=0x3e8,src=192.168.9.106,dst=192.168.9.105,ttl=127/0,tp_src=36860/0,tp_dst=8472/0,flags(-df-csum+key)),skb_mark(0/0),ct_state(0/0),ct_zone(0/0),ct_mark(0/0),ct_label(0/0),recirc_id(0),dp_hash(0/0),in_port(5),packet_type(ns=0,id=0),eth(src=52:54:00:26:d4:8e,dst=52:54:00:32:0f:71),eth_type(0x0800),ipv4(src=172.16.3.120/0.0.0.0,dst=172.16.3.110/0.0.0.0,proto=255/0,tos=0/0,ttl=127/0,frag=no),
> actions:4
>
> Out of five tests, only one of them started with this WARN message. And, the throughput rate
> degraded dramatically.
>
> Rhel7.4: kernel-693
> OVS: ovs 2.7

Do you have a script that can be used to reproduce this pvp testing?

> Thanks!
>
> Jean
>
> On 07/06/2017 06:51 AM, Joe Stringer wrote:
>
>  Please don't drop the list.
>
> Does dmesg list any messages from the OVS module?
>
> Which versions of ovs-vswitchd and the openvswitch.ko module are you using?
>
> On 6 July 2017 at 03:06, Saroj Pandey <sarojpandey574 at gmail.com> wrote:
>
>  Hi sir,
>
> Below the detail Logs
>
> dpif(handler2)|WARN|system at ovs-system: failed to put[create] (Invalid
> argument) ufid:68a252c5-eb36-4b01-b63e-9999a6bcd503
> skb_priority(0x6/0),in_port(1),skb_mark(0/0),eth(src=fa:16:3e:e8:e8:68,dst=01:00:5e:00:00:12),eth_type(0x0800),ipv4(src=169.254.192.2/0.0.0.0,dst=224.0.0.18/0.0.0.0,proto=112/0,tos=0xc0/0x3,ttl=255/0,frag=no),
> actions:set(tunnel(tun_id=0x25,src=192.168.12.5,dst=192.168.12.4,ttl=64,tp_dst=4789,flags(df|key))),9,push_vlan(vid=1,pcp=0),3
>
>
>
> dpif(handler2)|WARN|system at ovs-system: execute
> set(tunnel(tun_id=0x25,src=192.168.12.5,dst=192.168.12.4,ttl=64,tp_dst=4789,flags(df|key))),9,push_vlan(vid=1,pcp=0),3
> failed (Invalid argument) on packet
> ip,vlan_tci=0x0000,dl_src=fa:16:3e:e8:e8:68,dl_dst=01:00:5e:00:00:12,nw_src=169.254.192.2,nw_dst=224.0.0.18,nw_proto=112,nw_tos=192,nw_ecn=0,nw_ttl=255
>
>
> Thanks:-
> S PANDEY
>
> On Thu, Jul 6, 2017 at 3:25 PM, Joe Stringer <joe at ovn.org> wrote:
>
>  
> On 5 July 2017 at 23:44, Saroj Pandey <sarojpandey574 at gmail.com> wrote:
>
>  Dear Sir Kindly suggest me.How can resolve below the error?
>
> dpif(handler2)|WARN|system at ovs-system: failed to put[create] (Invalid
> argument) ufid:
>
>
> The above line by itself doesn't provide much context. Are there any
> further lines below it?
>
>
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-discuss
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-discuss


More information about the discuss mailing list