[ovs-discuss] DPDK adding port problem with VMXNET3

Reza Shaikhly rezashaikhly at gmail.com
Mon Oct 30 06:20:45 UTC 2017

Hello Everyone,

I have finally installed DPDK+OVS on my VM with CentOS 7. My virtual
machine has three “VMXNET3” NIC cards.

Things seem all right.

Actually i have used "igb_uio.ko" which is provided in DPDK library as PMD
driver. Guidelines states that it provides virtual functionality. As it
directed, two choices are vio and uio, i have tried both and the latter
worked to bind to vNIC.

After verifying all the aspects as directed on dpdk.org and
docs.openvswitch.org, I first added a testing bridge like this:

# ovs-vsctl add-br br0 -- set bridge br0 datapath_type=netdev

Then for adding a port:

# ovs-vsctl add-port br0 eth2 -- set Interface eth2 type=dpdk

And here is the problem:

ovs-vsctl: Error detected while setting up 'eth2': could not open network
device eth2 (No such device).  See ovs-vswitchd log for details.

ovs-vsctl: The default log directory is "/usr/local/var/log/openvswitch".

And “no such device” over and over again ...

And here is the output of dpdk devices (what I have highlighted in yellow
is actually “eth2” that I bound to dpdk earlier):

# $DPDK_DIR/usertools/dpdk-devbind.py --status | more

Network devices using DPDK-compatible driver


0000:13:00.0 'VMXNET3 Ethernet Controller 07b0' drv=igb_uio unused=

Network devices using kernel driver


0000:03:00.0 'VMXNET3 Ethernet Controller 07b0' if=eth0 drv=vmxnet3
unused=igb_uio *Active*

0000:0b:00.0 'VMXNET3 Ethernet Controller 07b0' if=eth1 drv=vmxnet3
unused=igb_uio *Active*

Other Network devices



Crypto devices using DPDK-compatible driver



Crypto devices using kernel driver



Other Crypto devices



Eventdev devices using DPDK-compatible driver



Eventdev devices using kernel driver



Other Eventdev devices



Mempool devices using DPDK-compatible driver



Mempool devices using kernel driver



Other Mempool devices



So, what is not right, please?


P.S: I have tried a lot and just stuck here and can’t add a port, ….please
help ….
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20171030/4902ece9/attachment.html>

More information about the discuss mailing list