[ovs-discuss] [ovs-dev] adding dpdk ports sharing same pci address to ovs-dpdk bridge

Kevin Traynor ktraynor at redhat.com
Thu Sep 7 18:54:14 UTC 2017


On 09/07/2017 06:47 PM, Darrell Ball wrote:
> Adding discuss at openvswitch.org
> 
> The related changes went into 2.7
> 
> 
> 
> On 9/7/17, 3:51 AM, "ovs-dev-bounces at openvswitch.org on behalf of devendra rawat" <ovs-dev-bounces at openvswitch.org on behalf of devendra.rawat.singh at gmail.com> wrote:
> 
>     Hi,
>     
>     I have compiled and built ovs-dpdk using DPDK v17.08 and OVS v2.8.0. The
>     NIC that I am using is Mellanox ConnectX-3 Pro, which is a dual port 10G
>     NIC. The problem with this NIC is that it provides only one PCI address for
>     both the 10G ports.
>     
>     So when I am trying to add the two DPDK ports to my br0 bridge
>     
>     # ovs-vsctl --no-wait add-port br0 dpdk0 -- set Interface dpdk0 type=dpdk
>     options:dpdk-devargs=0002:01:00.0
>     
>     # ovs-vsctl --no-wait add-port br0 dpdk1 -- set Interface dpdk1 type=dpdk
>     options:dpdk-devargs=0002:01:00.0
>     

Were you able to confirm those addresses by running ./dpdk-devbind.py -s
in your <dpdk_src>/tools dir?

>     The port dpdk1 is added successfully and able to transfer data, but adding
>     dpdk0 to br0 fails:
>     
>     2017-09-06T14:19:20Z|00045|netdev_dpdk|INFO|Port 0: e4:1d:2d:4f:78:60
>     2017-09-06T14:19:20Z|00046|bridge|INFO|bridge br0: added interface dpdk1 on
>     port 1
>     2017-09-06T14:19:20Z|00047|bridge|INFO|bridge br0: added interface br0 on
>     port 65534
>     2017-09-06T14:19:20Z|00048|dpif_netlink|WARN|Generic Netlink family
>     'ovs_datapath' does not exist. The Open vSwitch kernel module is probably
>     not loaded.
>     2017-09-06T14:19:20Z|00049|netdev_dpdk|WARN|'dpdk0' is trying to use device
>     '0002:01:00.0' which is already in use by 'dpdk1'
>     2017-09-06T14:19:20Z|00050|netdev|WARN|dpdk0: could not set configuration
>     (Address already in use)
>     2017-09-06T14:19:20Z|00051|bridge|INFO|bridge br0: using datapath ID
>     0000e41d2d4f7860
>     
>     
>     With OVS v2.6.1 I never had this problem as dpdk-devargs was not mandatory
>     and just specifying port name was enough to add that port to bridge.
>     
>     Is there a way to add port both ports to bridge ?
>     
>     Thanks,
>     Devendra
>     _______________________________________________
>     dev mailing list
>     dev at openvswitch.org
>     https://urldefense.proofpoint.com/v2/url?u=https-3A__mail.openvswitch.org_mailman_listinfo_ovs-2Ddev&d=DwICAg&c=uilaK90D4TOVoH58JNXRgQ&r=BVhFA09CGX7JQ5Ih-uZnsw&m=qO7NdgrrorJhievOguQLmsfEFuBcPfz9NfQX7UME1-8&s=ZKHbYlaTjm8VFj6Rggmcb2gw6s3xW4PxEtUy4YFG1VA&e= 
>     
> 
> _______________________________________________
> dev mailing list
> dev at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-dev
> 



More information about the discuss mailing list