[ovs-discuss] How to consistently implement VLAN forwarding/tagging in OVSDB

Bernie Ongewe o.bernie at gmail.com
Wed Sep 27 00:00:04 UTC 2017


Good day all

Trying to implement VLAN forwarding/membership with ovsdb-client but
getting very inconsistent behavior.

Following the discussion at
http://openvswitch.org/support/dist-docs/ovs-vswitchd.conf.db.5.txt this is
how I'd want to get x1 in native VLAN 100 and have those frames show up
tagged on VLAN 500.

Below is the output for;
sudo ovsdb-client dump tcp:<IP_ADDRESS>:6632 | egrep -A8 "Port table" |sed
"s/\s\+/ /g"| cut -f 1,12,19-21 -d" "

Port
_uuid name tag trunks vlan_mode
------------------------------------ ------------- --- ------ ---------
5a5e5a3a-7d4b-4bf1-9330-d3d18f07820d optumi-fabric [] [] []
7564a662-dc15-43f7-8941-5a7f5fba71c3 "x1" 100 [] access
6809e90e-c453-4e76-adce-649c9f5b5c69 "x2" 2 [] access
c1147892-65d2-4712-a1fb-13c245fe4faf "x3" 1 [] access
27efcbc9-36ea-4b88-a7e8-dda14d869651 "x4" [] [] access
089882a3-4221-4c94-a2c5-f0b2f65d2271 "x5" [] [] trunk


With this the frames at the other end are still untagged

I also tried this;

Port
_uuid name tag trunks vlan_mode
------------------------------------ ------------- --- ------ ---------
5a5e5a3a-7d4b-4bf1-9330-d3d18f07820d optumi-fabric [] [] []
7564a662-dc15-43f7-8941-5a7f5fba71c3 "x1" 100 [] access
6809e90e-c453-4e76-adce-649c9f5b5c69 "x2" 2 [] access
c1147892-65d2-4712-a1fb-13c245fe4faf "x3" 1 [] access
27efcbc9-36ea-4b88-a7e8-dda14d869651 "x4" [] [] access
089882a3-4221-4c94-a2c5-f0b2f65d2271 "x5" [] [100] trunk


I've tried many permutations but, only on the rare occassion, get frames
tagged in one direction for a few seconds.

Is there a bug I'm stepping on or any way I can consistently accomplish
this?

This is on ovs_version: "2.6.1"

Cheers
Bernie
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20170926/82f2d726/attachment-0001.html>


More information about the discuss mailing list