[ovs-discuss] Have to write whole path for using utilities

Att Att attkillrocks at gmail.com
Thu Feb 8 04:19:52 UTC 2018


Hi

Thanks for your replies. I resolved it by installing latest debian
packages. Now its working well.
I have encountered another problem with the following error logs:

2018-02-08T04:11:08Z|00004|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
connecting...
2018-02-08T04:11:08Z|00005|reconnect|INFO|unix:/var/run/openvswitch/db.sock:
connected
2018-02-08T04:11:08Z|00006|dpdk|ERR|DPDK not supported in this copy of Open
vSwitch.
*2018-02-08T04:11:08Z|00007|ofproto_dpif|INFO|netdev at ovs-netdev: Datapath
supports recirculation*
2018-02-08T04:11:08Z|00008|ofproto_dpif|INFO|netdev at ovs-netdev: VLAN header
stack length probed as 1
2018-02-08T04:11:08Z|00009|ofproto_dpif|INFO|netdev at ovs-netdev: MPLS label
stack length probed as 3
.
.
.
*2018-02-08T04:11:08Z|00022|netdev|WARN|could not create netdev vhost-user2
of unknown type dpdkvhostuser*
*2018-02-08T04:11:08Z|00023|bridge|WARN|could not open network device
vhost-user2 (Address family not supported by protocol)*
2018-02-08T04:11:08Z|00024|bridge|INFO|bridge bridge1: added interface
bridge1 on port 65534
2018-02-08T04:11:08Z|00025|bridge|INFO|bridge bridge1: using datapath ID
0000f6f547d29940
2018-02-08T04:11:08Z|00026|connmgr|INFO|bridge1: added service controller
"punix:/var/run/openvswitch/bridge1.mgmt"


Is it because of I am using dpdk 17.05.2 with ovs 2.8.1? If these two
versions are not compatible then which versions should I use?
I checked the compatibility  before using the both versions from this link "
http://docs.openvswitch.org/en/latest/faq/releases/".
Please help.

Thanks and regards
Att

On Thu, Feb 8, 2018 at 2:35 AM, Ben Pfaff <blp at ovn.org> wrote:

> On Wed, Feb 07, 2018 at 02:27:20PM +0800, Attitude Killer wrote:
> > I cloned ovs from github. When I use this command "ovsdb-tool create
> > /usr/local/etc/openvswitch/conf.db \  vswitchd/vswitch.ovsschema"
> >
> > I get an error saying :* "The program 'ovsdb-tool' is currently not
> > installed. You can install it by typing:*
> > *sudo apt install openvswitch-switch"*
> >
> >
> > Installing openvswitch-switch via apt installs 2.5 version of ovs
> whereas I
> > want to use 2.8.1.
> >
> > I make it work by writing the whole path to the ovsdb folder and also the
> > same happens with using utilities. For example:
> >
> > *$ /home/att/ovs/utilities/ovs-vsctl --version*
> >
> > Please help me with the solution of this problem.
>
> It sounds like you didn't install OVS.  The installation instructions
> are in Documentation/intro/install/general.rst.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20180208/76b35ddc/attachment.html>


More information about the discuss mailing list