[ovs-discuss] Unable to bridge adapters in Windows

aserdean at ovn.org aserdean at ovn.org
Tue Feb 13 17:36:44 UTC 2018


Hi Jacob,

 

I can try to help as much as I can.

 

Can you run me through the steps that you already tried (from get-netadapter, through the vmswitch creation and how you tried to add the ports to OVS)?

 

Thanks,

Alin.

 

De la: ovs-discuss-bounces at openvswitch.org [mailto:ovs-discuss-bounces at openvswitch.org] În numele Jacob Broussard
Trimis: Friday, January 5, 2018 11:00 PM
Către: ovs-discuss at openvswitch.org
Subiect: [ovs-discuss] Unable to bridge adapters in Windows

 

Apologies if this is too simple, but I've been struggling with this for a few days now.

 

I have open vswitch installed under windows server 2016 and am unable to even perform the simplest things such as bridging two adapters.  I chose to do that because it seems like a simple 'hello world' type of thing.  I've got 3 NICs on this computer, and two test VMs running debian.  It seems that half the time I get the error message "could not add network device X to ofproto (Invalid Argument)".  The other half it adds, but I can't pass traffic.  I've never been able to add more than 1 interface successfully.  Ususally after the first one is successfully added, adding the second causes them both to fail.

 

Scenarios I'd like to do (as a hello world! exercise):

 

Bridge physical interface to a VM.

 

Bridge two VMs together.

 

Any advice for how to go about this?

 

Thanks!

-Jacob

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20180213/517f563f/attachment.html>


More information about the discuss mailing list