[ovs-discuss] mtu_request

Chris Boley ilgtech75 at gmail.com
Sat Mar 3 13:32:17 UTC 2018


OVS:
foo at VMHOST:~$ sudo ovs-vsctl show
126a4b57-4837-42a9-95d6-d818b35e95bd
   Bridge "vbridge0"
       Port "vnet0"
           tag: 2
           Interface "vnet0"
       Port "vbond0"
           Interface "eth2"
           Interface "eth1"
       Port "vbridge0"
           Interface "vbridge0"
               type: internal
   ovs_version: "2.5.2"

I've tried changing MTU parameters on my internal vbridge0 interface:

sudo ovs-vsctl set interface vbridge0 mtu=1520

This command runs, but does nothing to the MTU of my internal bridge
interface.

There's supposed to be a separate command:
ovs-vsctl set int vbridge0 mtu_request=1520

<column name="mtu_request"
              type='{"type": "integer", "minInteger": 1}'>
        <p>
          Requested MTU (Maximum Transmission Unit) for the interface. A
client
          can fill this column to change the MTU of an interface.
        </p>


I get this back when running the command:
ovs-vsctl: Interface does not contain a column whose name matches
"mtu_request"

What am I doing wrong?
All other interfaces in my bridge for example the eth1 and eth2 of my
vbond0,
and the vnet0 being created by libvirt is setting itself to 1520 by way of
the guest's /etc/network/interfaces file and shows 1520 values when I run
the
* list interface vnet0 command.

is the mtu_request= a deprecated option?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20180303/e7592b04/attachment.html>


More information about the discuss mailing list