[ovs-discuss] ISSUE with IPERF in OVS - GRE Setup

Swathin S swathins079 at gmail.com
Mon Mar 5 08:52:43 UTC 2018


Hi,

I am having the following topology with gre tunnel. Whenever I start iperf
with the BR1 IPs, I am 0 packets reaching the other side.

Topology
---------

(10.0.0.10)BR1 BR0(192.168.1.10)-----(phyical link)---(192.168.1.11)BR0
BR1(10.0.0.11)

OVS logs
---------

192.168.1.11
-------------------------------------------------
# ovs-vsctl show
28ec0ec0-4d41-4ee0-a688-59363e990be2
    Bridge "br1"
        Port "gre1"
            Interface "gre1"
                type: gre
                options: {remote_ip="192.168.1.10"}
        Port "br1"
            Interface "br1"
                type: internal
    Bridge "br0"
        Port "br0"
            Interface "br0"
                type: internal
        Port "eth2"
            Interface "eth2"
    ovs_version: "2.0.2"

# ovs-ofctl dump-ports br1
OFPST_PORT reply (xid=0x2): 2 ports
  port  1: rx pkts=191, bytes=16192, drop=0, errs=0, frame=0, over=0, crc=0
           tx pkts=324, bytes=218080, drop=0, errs=0, coll=0
  port LOCAL: rx pkts=205, bytes=13834, drop=0, errs=0, frame=0, over=0,
crc=0
           tx pkts=277, bytes=186885, drop=0, errs=0, coll=0
# ovs-ofctl dump-ports br0
OFPST_PORT reply (xid=0x2): 2 ports
  port  1: rx pkts=1756592, bytes=2469177682, drop=0, errs=60, frame=0,
over=0, crc=0
           tx pkts=2523136, bytes=3696929018, drop=0, errs=0, coll=0
  port LOCAL: rx pkts=228910, bytes=2358163654, drop=0, errs=0, frame=0,
over=0, crc=0
           tx pkts=146232, bytes=3529991526, drop=0, errs=0, coll=0
root at ubuntu:/home/sanctum#


192.168.1.10
-------------------------------------------------
# ovs-vsctl show
3e0b4065-425b-4f76-b0b9-00ff062ca2b1
    Bridge "br1"
        Port "br1"
            Interface "br1"
                type: internal
        Port "gre1"
            Interface "gre1"
                type: gre
                options: {remote_ip="192.168.1.11"}
    Bridge "br0"
        Port "eth2"
            Interface "eth2"
        Port "br0"
            Interface "br0"
                type: internal
    ovs_version: "2.5.2"

# ovs-ofctl dump-ports br1
OFPST_PORT reply (xid=0x2): 2 ports
  port LOCAL: rx pkts=218, bytes=72490, drop=0, errs=0, frame=0, over=0,
crc=0
           tx pkts=217, bytes=18021, drop=0, errs=0, coll=0
  port  2: rx pkts=247, bytes=20414, drop=0, errs=0, frame=0, over=0, crc=0
           tx pkts=268, bytes=103812, drop=0, errs=0, coll=0
root at ubuntusoekris3:/home/sanctumsoekris3#
# ovs-ofctl dump-ports br0
OFPST_PORT reply (xid=0x2): 2 ports
  port LOCAL: rx pkts=172401, bytes=2357681766, drop=0, errs=0, frame=0,
over=0, crc=0
           tx pkts=229444, bytes=3535382058, drop=0, errs=0, coll=0
  port  1: rx pkts=5355249, bytes=7469372659, drop=0, errs=70, frame=0,
over=0, crc=0
           tx pkts=3193175, bytes=4052911200, drop=0, errs=0, coll=0
root at ubuntusoekris3:/home/sanctumsoekris3#

IPERF OUTPUT
=============
Client-Side
-------------
# iperf3 -c 10.0.0.11
Connecting to host 10.0.0.11, port 5201
[  4] local 10.0.0.10 port 51633 connected to 10.0.0.11 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec  84.8 KBytes   694 Kbits/sec    2   1.41
KBytes
[  4]   1.00-2.00   sec  0.00 Bytes  0.00 bits/sec    1   1.41 KBytes
[  4]   2.00-3.00   sec  0.00 Bytes  0.00 bits/sec    0   1.41 KBytes
[  4]   3.00-4.00   sec  0.00 Bytes  0.00 bits/sec    1   1.41 KBytes
[  4]   4.00-5.00   sec  0.00 Bytes  0.00 bits/sec    0   1.41 KBytes
[  4]   5.00-6.00   sec  0.00 Bytes  0.00 bits/sec    0   1.41 KBytes
[  4]   6.00-7.00   sec  0.00 Bytes  0.00 bits/sec    1   1.41 KBytes
[  4]   7.00-8.00   sec  0.00 Bytes  0.00 bits/sec    0   1.41 KBytes
[  4]   8.00-9.00   sec  0.00 Bytes  0.00 bits/sec    0   1.41 KBytes
[  4]   9.00-10.00  sec  0.00 Bytes  0.00 bits/sec    0   1.41 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  84.8 KBytes  69.5 Kbits/sec    5             sender
[  4]   0.00-10.00  sec  0.00 Bytes  0.00 bits/sec                  receiver

Server
-------
# iperf3 -s
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 10.0.0.10, port 51632
[  5] local 10.0.0.11 port 5201 connected to 10.0.0.10 port 51633
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-1.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   1.00-2.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   2.00-3.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   3.00-4.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   4.00-5.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   5.00-6.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   6.00-7.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   7.00-8.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   8.00-9.00   sec  0.00 Bytes  0.00 bits/sec
[  5]   9.00-10.00  sec  0.00 Bytes  0.00 bits/sec
[  5]  10.00-10.03  sec  0.00 Bytes  0.00 bits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  5]   0.00-10.03  sec  84.8 KBytes  69.3 Kbits/sec    5             sender
[  5]   0.00-10.03  sec  0.00 Bytes  0.00 bits/sec                  receiver

Could you please let me know why this is happening. Am i doing something
wrong?

Regards,
Swathin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20180305/6e49df3c/attachment-0001.html>


More information about the discuss mailing list