[ovs-discuss] Issue with setting ovs in a vm

Ben Pfaff blp at ovn.org
Fri Mar 16 20:24:39 UTC 2018


For what it's worth, "local" and "random" usually mean the same thing.

On Thu, Mar 15, 2018 at 12:34:33PM +0530, Neelakantam Gaddam wrote:
> Hi Ashish,
> 
> 
> The bridge mac address is not picked-up from its ports if the port mac
> address is multicast, reserved, local or zero.
> Please check the mac address of the port you are adding to the bridge. My
> guess is that the mac address of the port is having local bit set.
> 
> 
> On Thu, Mar 15, 2018 at 8:44 AM, Ashish Karki <ashish.karki19 at gmail.com>
> wrote:
> 
> > Hi,
> > We are Creating a  ovs-bridge and adding a port to it in a vm. Usually
> > when we add the port to the ovs-br the mac of the port gets attached to the
> > bridge. But this is not the case when done inside vm
> > Instead br keeps its random mac.
> > Just to give you the reference we are trying to deploy openstack via
> > kolla-ansible inside a vm and br-ex keeps getting random mac instead of
> > neutron external interface.
> > Any help would be appriciated
> >
> > Br,
> > Ashish Karki
> >
> > _______________________________________________
> > discuss mailing list
> > discuss at openvswitch.org
> > https://mail.openvswitch.org/mailman/listinfo/ovs-discuss
> >
> >
> 
> 
> -- 
> Thanks & Regards
> Neelakantam Gaddam

> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-discuss



More information about the discuss mailing list