[ovs-discuss] A doubt about slow speed of ovs in userspace at about 3KB/s

逆光倾城 461123052 at qq.com
Tue Nov 20 02:38:08 UTC 2018

  I'm an engineer who offen use  OpenVSwtich, also develop on it. But I found a bug a few days ago, it can also be said as a doubt. As follows:
  I Deploy OVS on a physical Computer with CentOS 7,It has two onboard PCI NICs,and then config OVS work in userspace without kernel,"ovs-vsctl set bridge br0 datapath_type=netdev". 
Strange things happened, The speed was only 3KB/s(about 24Kbps), But there was not this problem with use kernel module, In kernel space, it can work as a Gigabit switch.
I attempted to do something below:
1.I tried other PCI NICs like:(RealTek RTL8111 Gigabit 、intel 82566DM Gigabit 、Broadcom BCM5705 Gigabit ), the bug always with me, It tranlated with only 3KB/s;
2.I tried other USB NICs like:(Realtek  RTL8152  100Mbps、ASIX  AX88772B 100Mbps)  
a.AX88772B  tranlated 12MB/s,about 100Mbps bandwith;
b.RTL8152 has the same bug like PCI NICs, only 3KB/s.
For detail:

Can I guess as follow?
1.PCI NICs has something wrong work in userspace?
2.Some USB NICs work rightly in userspace,but some are not?
3.Any Difference between their driver program,or linux system?
I beg your help:
1.I want get all packages with funciton "dp_netdev_execute_actions()" in dpif-netdev.c;
2.Is there any other way which can get all packages in userspace, when I config ovs work with kernel space?
3.Whether it is a bug,and be solved in further version?


461123052 at qq.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20181120/92eaec3f/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 668B90D7 at 520CB234.9073F35B.png.jpg
Type: image/jpeg
Size: 28446 bytes
Desc: not available
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20181120/92eaec3f/attachment-0001.jpg>

More information about the discuss mailing list