[ovs-discuss] (no subject)

Ramzah Rehman ramzahrehman at gmail.com
Fri Nov 23 12:43:09 UTC 2018


Hi!

I have 2 virtual machines on VMware.  VM one has ovs 2.9.4 installed with
DPDK version 17.11.4. VM one has open vSwitch br0. br0 has IP:10.0.0.5 and
eth0 of VM two has IP: 10.0.0.14  I have following entries installed on
switch br0:

ovs-ofctl -O OpenFlow15 add-meter br0 meter=1,kbps,band=type=drop,rate=500

ovs-ofctl -O OpenFlow15 add-flow br0 arp,in_port=1,actions=output:LOCAL
ovs-ofctl -O OpenFlow15 add-flow br0 arp,in_port=LOCAL,actions=output:1
ovs-ofctl -O OpenFlow15 add-flow br0 ip,ip_dst=
10.0.0.5/255.255.255.255,actions=output:LOCAL
ovs-ofctl -O OpenFlow15 add-flow br0 ip,ip_dst=
10.0.0.14/255.255.255.255,actions=meter=1,output:1

Now I was experimenting with rate-limiting (metering) feature in OVS. When
I give rate of 500 I get bandwidth of 600Mbps for TCP traffic from VM one
to VM two (done vie iperf). For rate 5000 I get 4.92Mbps. Both of these are
fine. When I change rate to 50000 I get bandwidth of 30Mbps, whereas
expected bandwidth is around 48-49Mbps. Please let me know what is going
wrong here.

One more question. I just need to use metering feature of ovs. Do I need to
add interfaces to VIFO for that? I am asking this because adding interfaces
to VIFO gave errors.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20181123/0c7a1ce1/attachment.html>


More information about the discuss mailing list