[ovs-discuss] OvS segfault when starting test-dpdkr

avatli at itu.edu.tr avatli at itu.edu.tr
Thu Aug 8 07:42:42 UTC 2019

Hello community

I'm trying to run the test-dpdkr application but it causes  
segmentation fault in ovs-vswitchd as below.

Aug  2 21:48:32 ulak ovs-vsctl: ovs|00001|vsctl|INFO|Called as  
ovs-vsctl add-port br0 dpdkr0 -- set Interface dpdkr0 type=dpdkr
Aug  2 21:49:50 ulak test-dpdkr[31039]: EAL: Probing VFIO support...
Aug  2 21:49:50 ulak test-dpdkr[31039]: APP: Finished Process Init.
Aug  2 21:49:50 ulak kernel: [ 2172.400789] show_signal_msg: 9  
callbacks suppressed
Aug  2 21:49:50 ulak kernel: [ 2172.400795] pmd32[31036]: segfault at  
6e00000088 ip 0000000000a707c9 sp 00007fb40f7fc050 error 6 in  

ulak at ulak:~$ addr2line -e /usr/local/sbin/ovs-vswitchd 0000000000a707c9

First, I tried OvS 2.11.0 and DPDK 18.11.2 version written on OVS  
releases, but the same seqfault was there, then I used the latest OVS  
and DPDK (it has a build error for RTE_COLOR_GREEN, I fixed it), and  
still the same problem

root at ulak:/home/ulak# ovs-vswitchd --version
ovs-vswitchd (Open vSwitch) 2.12.90
DPDK 19.05.0

I just followed the steps in [1], and this problem arises every time,  
my setup is as follows:

root at ulak:/home/ulak# ovs-vsctl show
     Bridge br0
         datapath_type: netdev
         Port dpdkr0
             Interface dpdkr0
                 type: dpdkr
         Port br0
             Interface br0
                 type: internal
     ovs_version: "2.12.90"

root at ulak:/home/ulak/ovs-master/tests# ./test-dpdkr -c 1 -n 4  
--proc-type=secondary -- -n 0
EAL: Detected 4 lcore(s)
EAL: Detected 1 NUMA nodes
EAL: Multi-process socket /var/run/dpdk/rte/mp_socket_31039_4ad8f644b92
EAL: Probing VFIO support...
APP: Finished Process Init.

Client process 0 handling packets
[Press Ctrl-C to quit ...]

ulak at ulak:~$ uname -a
Linux ulak 4.4.0-157-generic #185-Ubuntu SMP Tue Jul 23 09:17:01 UTC  
2019 x86_64 x86_64 x86_64 GNU/Linux

ulak at ulak:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.6 LTS
Release:	16.04
Codename:	xenial

Last, I was using the test-dpdkr without any problem with the OvS version 2.7.

Thanks in advance..

- Volkan

[1] http://docs.openvswitch.org/en/latest/topics/dpdk/ring/

More information about the discuss mailing list