[ovs-discuss] [ovn][clustered] Confusing to create ovsdb-server clustered databases

Zufar Dhiyaulhaq zufar at onf-ambassador.org
Wed Aug 28 10:33:15 UTC 2019


[ovn][clustered] Confusing to create ovsdb-server clustered databases

Hi Everyone, I have successfully created OpenStack with OVN enabled. But
the problem comes when I try to cluster the ovsdb-server. My scenario is
trying to cluster the ovsdb-server databases but only using single
ovn-northd.

My cluster:
- controller0 : 10.100.100.100 / 10.101.101.100 (ovn-northd, ovsdb-server,
neutron server)
- controller1 : 10.100.100.101 / 10.101.101.101 (ovsdb-server)
- controller2 : 10.100.100.102 / 10.101.101.102 (ovsdb-server)
- compute1 : 10.100.100.103 / 10.101.101.103
- compute2 : 10.100.100.104 / 10.101.101.104
- compute3 : 10.100.100.105 / 10.101.101.105

10.100.100.0/24 : Management Network
10.101.101.0/24 : Data Network

I have installed the OpenStack using the manual method. Below is the step
to create ovsdb-server and neutron services.
- step 1: bootstrapping ovsdb-server cluster :
http://paste.openstack.org/show/766463/
- step 2: creating neutron service in controller :
http://paste.openstack.org/show/766464/
- step 3: creating neutron service in compute :
http://paste.openstack.org/show/766465/

But when I try to create neutron resource, Its always hang (only neutron
resource).

This is the full logs of all nodes, contain:
http://paste.openstack.org/show/766461/
- all openvswitch logs
- port (via netstat)
- step bootstraping ovsdb-server

Neutron logs in controller0: paste.openstack.org/show/766462/

Anyone know why stuck? Are my step is wrong?

Thank you.

Best Regards,
Zufar Dhiyaulhaq
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190828/002c16bd/attachment-0001.html>


More information about the discuss mailing list