[ovs-discuss] 答复: openvswitch.ko replacement

pei Jikui jkpei at hotmail.com
Thu Jan 24 12:36:25 UTC 2019

more information about the errors.
1) when tried "insmod openvswitch"
[root at localhost ovs]# insmod ./datapath/linux/openvswitch.ko
insmod: ERROR: could not insert module ./datapath/linux/openvswitch.ko: File exists

2) When I tried "rmmod openvswitch"

rmmod: ERROR: Module openvswitch is in use

3) After "ovs-vsctl del-br " all the bridges, the above two commands run well.



发件人: ovs-discuss-bounces at openvswitch.org <ovs-discuss-bounces at openvswitch.org> 代表 pei Jikui <jkpei at hotmail.com>
发送时间: 2019年1月24日 18:43
收件人: ovs-discuss at openvswitch.org
主题: [ovs-discuss] openvswitch.ko replacement


In the ovs version 2.9.10, I made some changes in the datapath and want to replace the openvswtich.ko with the new built one.
While I couldn't insmod this new openvswitch.ko unless I delete all the bridges using "ovs-vsctl del-br *".

Is this by design or there are some ways to avoid deleting the bridges in order to replace the new openvswitch.ko?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190124/aa756dbd/attachment.html>

More information about the discuss mailing list