[ovs-discuss] Controller + dot1Q trunk

Heim, Dennis Dennis.Heim at wwt.com
Wed Jul 3 21:25:24 UTC 2019


OvS Version: 2.5.8
ONOS Controller Version: 2.1

My topology is I have VLANs (10,11,12, 15) configured as access ports on the OvS. I also have a VLAN trunk terminating on my Cisco CSR1K. I have layer 3 interfaces on the CSR1Kv. When the OvS is standalone it works without a problem. However, when I connect it to the ONOS controller, pings do not reach the CSR1K. With some testing, it appears when connected to the controller, it is not sending the vlan tags. If I go to the CSR1Kv and configure VLAN10 as the native vlan, then VLAN 10 can ping the interface.

Is there something that has to be done when connected to a controller to get it to VLAN tag the traffic?

0086fc1b-9bc6-4319-a9e8-e8fe2eae1a10
    Bridge data
        Port data
            Interface data
                type: internal
        Port "gi5"
            tag: 11
            Interface "gi5"
        Port "gi1"
            tag: 10
            Interface "gi1"
        Port "vlan10"
            tag: 10
            Interface "vlan10"
                type: internal
        Port "gi2"
            tag: 11
            Interface "gi2"

interface GigabitEthernet2.10
description ** Internal VLAN (10) **
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
ip nat inside
!
interface GigabitEthernet2.11
description ** Leaf2 VLAN (11) **
encapsulation dot1Q 11
ip address 192.168.11.1 255.255.255.0
ip nat inside
!
interface GigabitEthernet2.12
description ** SME VLAN (12) **
encapsulation dot1Q 12
ip address 192.168.12.1 255.255.255.0
ip nat inside
!
interface GigabitEthernet2.15
description ** VDI VLAN (15) **
encapsulation dot1Q 15
ip address 192.168.15.1 255.255.255.0
ip nat inside


Dennis Heim | Domain Architect (Collaboration Labs)
World Wide Technology, Inc. | +1 314-212-1814
[cid:image001.png at 01D10DD2.7FC81F90]<https://twitter.com/CollabSensei>
[cid:image002.png at 01D10DD2.7FC81F90]<xmpp:dennis.heim at wwt.com>[cid:image003.png at 01D10DD2.7FC81F90]<tel:+13142121814>[cid:image004.png at 01D10DD2.7FC81F90]<sip:dennis.heim at wwtatc.com>
"The most powerful person in the world is the story teller. The storyteller sets the vision, values and agenda of an entire generation that is to come" - Steve Jobs
"Leaders who don't listen will eventually be surrounded by people who have nothing to say" --- Andy Stanley
"Worry less about who you might offend, and more about who you might inspire" -- Tim Allen
"Imagination is more important than knowledge."  -- Albert Einstein
"If you can raise the level of effort and performance in those around you, you are officially a leader" - Urban Meyer
"The greatest danger for most of us is not that our aim is too high and we miss it, but that it is too low and we reach it." -- Michelangelo Buonarroti
"Mediocore managers play checkers (assuming everyone is the same). Great managers play chess (acknowledging that everyone is unique)" - Marcus Buckingham
"If you're not failing every now and again, it's a sign you're not doing anything very innovative" - Woody Allen

Click here to join me in my Collaboration Meeting Room<https://wwt.webex.com/meet/dennis.heim>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190703/793ae6a7/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.gif
Type: image/gif
Size: 4226 bytes
Desc: image001.gif
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190703/793ae6a7/attachment-0004.gif>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image002.gif
Type: image/gif
Size: 2017 bytes
Desc: image002.gif
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190703/793ae6a7/attachment-0005.gif>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image003.gif
Type: image/gif
Size: 2014 bytes
Desc: image003.gif
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190703/793ae6a7/attachment-0006.gif>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image004.gif
Type: image/gif
Size: 1939 bytes
Desc: image004.gif
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190703/793ae6a7/attachment-0007.gif>


More information about the discuss mailing list