[ovs-discuss] Help with testing please

Vasu Dasari vdasari at gmail.com
Fri Jun 21 12:18:42 UTC 2019


Hi,

I would like to know what is the procedure you follow to debug "Testing"
failures.

For example, on my Ubuntu system, I am trying to execute system-userspace
test case like this.

sudo make -C _build-gcc/ -s check-system-userspace TESTSUITEFLAGS='-k "ptap
- triangle bridge setup with L2 and L3 GRE tunnels"'

This is failing on my system. I would like to debug this by starting a
switch with the same configuration that was done on the switch.

I do see that test related information is present at
tests/system-userspace-testsuite.dir/139. And there is a script called
"run" which can be used to redo the test. But, ovs-vswitchd is killed when
script fails.

1. Are there any options I can give to ./run or to "testsuite" to not to
perform kill operation so that I can continue to debug the switch from
where it failed.
2. How can I recreate the switch instance from conf.db we got from failed
test? I tried to copy conf.db to "ovs/_run" directory and started
"utilities/ovs-dev.py
run" to start the switch. But, not all interfaces created properly. For
example, on some interfaces I do see errors like this. So probably I might
be missing some steps here.
        Port "p2-0"
            Interface "p2-0"
                error: "could not open network device p2-0 (No such device)"

Thanks
-Vasu

*Vasu Dasari*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20190621/b3a6bc29/attachment.html>


More information about the discuss mailing list