[ovs-discuss] OpenShift / KVM (OVS) network latency timeouts

Sven Vogel S.Vogel at ewerk.com
Wed Sep 11 09:37:01 UTC 2019


Hi there,

We think we have some problems with our virtualisation infrastructure and opemvswitch environment.

We encounter any curious problems.

We use Fujitsu Hosts with the following setup.

OpenShift Settings:
OKD:                            3.11
openvswitch version:    2.7.0


KVM Host Settings:
CentOS version:         7.6.1810
kernel version:                 3.10.0-957.21.3.el7.x86_64
qemu version:                   qemu-kvm-ev-2.10.0-21.el7_5.7.1
libvirtd version:               5.0.0
openvswitch version:    2.11.0
openvswitch db version: 7.16.1
puppet agent version:   5.5.14

It seems that we have strange problems because we run …

KVM (qemu/libvirt) -> OVS -> VM -> OVS (vxlan inside of the OpenShift VMs) -> docker container

Inside of the OpenShift VMs is looks like we get always network timeouts and high latency.

If we check netstat -s we see inside of a machine of OpenvSwitch the following

Tcp:
   1477858 active connections openings
   664429 passive connection openings
   425095 failed connection attempts
   416553 connection resets received
   439 connections established
   313764872 segments received
   379372777 segments send out
   409605 segments retransmited
   246 bad segments received.
   1629884 resets sent

If we run ping from one docker container -> docker container we get high ping rate … they move up and down …

64 bytes from 10.32.24.76: icmp_seq=5 ttl=64 time=1.09 ms
64 bytes from 10.32.24.76: icmp_seq=6 ttl=64 time=0.264 ms
64 bytes from 10.32.24.76: icmp_seq=7 ttl=64 time=0.292 ms
64 bytes from 10.32.24.76: icmp_seq=8 ttl=64 time=0.243 ms
64 bytes from 10.32.24.76: icmp_seq=9 ttl=64 time=1.05 ms
64 bytes from 10.32.24.76: icmp_seq=10 ttl=64 time=0.292 ms
64 bytes from 10.32.24.76: icmp_seq=11 ttl=64 time=0.258 ms
64 bytes from 10.32.24.76: icmp_seq=12 ttl=64 time=2.57 ms
64 bytes from 10.32.24.76: icmp_seq=13 ttl=64 time=0.260 ms
64 bytes from 10.32.24.76: icmp_seq=14 ttl=64 time=0.152 ms
64 bytes from 10.32.24.76: icmp_seq=15 ttl=64 time=0.269 ms

There are any ideas what could be the problem?

Thanks and help

Sven

__

Sven Vogel
Teamlead Platform

EWERK DIGITAL GmbH
Brühl 24, D-04109 Leipzig
P +49 341 42649 - 99
F +49 341 42649 - 98
S.Vogel at ewerk.com
www.ewerk.com

Geschäftsführer:
Dr. Erik Wende, Hendrik Schubert, Frank Richter
Registergericht: Leipzig HRB 9065

Zertifiziert nach:
ISO/IEC 27001:2013
DIN EN ISO 9001:2015
DIN ISO/IEC 20000-1:2011

EWERK-Blog | LinkedIn | Xing | Twitter | Facebook

Auskünfte und Angebote per Mail sind freibleibend und unverbindlich.

Disclaimer Privacy:
Der Inhalt dieser E-Mail (einschließlich etwaiger beigefügter Dateien) ist vertraulich und nur für den Empfänger bestimmt. Sollten Sie nicht der bestimmungsgemäße Empfänger sein, ist Ihnen jegliche Offenlegung, Vervielfältigung, Weitergabe oder Nutzung des Inhalts untersagt. Bitte informieren Sie in diesem Fall unverzüglich den Absender und löschen Sie die E-Mail (einschließlich etwaiger beigefügter Dateien) von Ihrem System. Vielen Dank.

The contents of this e-mail (including any attachments) are confidential and may be legally privileged. If you are not the intended recipient of this e-mail, any disclosure, copying, distribution or use of its contents is strictly prohibited, and you should please notify the sender immediately and then delete it (including any attachments) from your system. Thank you.


More information about the discuss mailing list