[ovs-discuss] make check-afxdp tests failing

Conor Black cblack39 at qub.ac.uk
Sat Nov 14 14:32:49 UTC 2020


After following the OvS with AF_XDP installation instructions at https://docs.openvswitch.org/en/latest/intro/install/afxdp/ and without encountering any problems, every test fails when I run make check-afxdp. All tests seem to fail in the same way, with system-afxdp-testsuite.log showing repetitions of:

3: ovs-netdev: <BROADCAST,MULTICAST,PROMISC> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000

Followed by:

system-traffic.at:27: wait failed after 30 seconds
./ovs-macros.at:241: hard failure

I doubt that this is a bug but I have tried to run with different versions of Ubuntu (currently running version 20.10 with kernel 5.8.0) and am getting the same error every time. The OpenVSwitch version is 2.13.90.

Would anyone be able to tell me what I am doing wrong?

Thanks,
Conor
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20201114/d36e52cb/attachment.html>


More information about the discuss mailing list