[ovs-discuss] OVS 2.11.1 RPM build from source fails on Oracle Linux 7.8 and 7.9

Gilbert Standen gilstanden at hotmail.com
Mon Nov 16 16:55:31 UTC 2020


Greg, thanks!  You are exactly right. We standardized Orabuntu-LXC on 2.12.1 which fixed the problem because it's one of the release that has Aaron's patch built in. If end users want to use other versions, it's easy for them to reconfigure Orabuntu-LXC to do so.
________________________________
From: Gregory Rose <gvrose8192 at gmail.com>
Sent: Monday, November 16, 2020 10:48 AM
To: Gilbert Standen <gilstanden at hotmail.com>; ovs-discuss at openvswitch.org <ovs-discuss at openvswitch.org>
Subject: Re: [ovs-discuss] OVS 2.11.1 RPM build from source fails on Oracle Linux 7.8 and 7.9



On 11/12/2020 8:26 PM, Gilbert Standen wrote:
> Hi,
>
> OVS 2.11.1 RPM builds and install fine on Oracle Linux 7.6, but on Oracle Linux 7.8 and 7.9 the RPM build fails with the following errors:
>
> In file included from lib/netlink-conntrack.c:27:0:
> /usr/include/linux/netfilter/nf_conntrack_sctp.h:25:2: error: unknown type name 'u8'
>    u8 last_dir;
>    ^
> /usr/include/linux/netfilter/nf_conntrack_sctp.h:26:2: error: unknown type name 'u8'
>    u8 flags;
>    ^
> make[2]: *** [lib/netlink-conntrack.lo] Error 1
> make[2]: Leaving directory `/opt/olxc/home/ubuntu/Downloads/orabuntu-lxc-master/uekulele/openvswitch/rpmbuild/BUILD/openvswitch-2.11.1'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/opt/olxc/home/ubuntu/Downloads/orabuntu-lxc-master/uekulele/openvswitch/rpmbuild/BUILD/openvswitch-2.11.1'
> make: *** [all] Error 2
> error: Bad exit status from /var/tmp/rpm-tmp.s2PkRp (%build)
>
> RPM build errors:
>      Bad exit status from /var/tmp/rpm-tmp.s2PkRp (%build)
>
> I've looked at these URLs below, but do not know how to make use of them to get the RPM build working on Oracle Linux 7.8 and 7.9 (I have not tested Oracle Linux 7.7 yet).
>
> https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fbugzilla.redhat.com%2Fshow_bug.cgi%3Fid%3D1890095&data=04%7C01%7C%7Ca92119d3193748d1be3908d88a4f85b9%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637411421428266492%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=QwqKZqSg%2FIA5urH5lDSBTCxZDzjKXBqrl3%2FNs9xzii8%3D&reserved=0
> and
> https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fopenvswitch%2Fovs%2Fcommit%2F8c7130da98c55bdf13eae62b5250434f8dfd366b&data=04%7C01%7C%7Ca92119d3193748d1be3908d88a4f85b9%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637411421428266492%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=ewM%2FG5XJs3QLBl5dM24kUus4rWHdxrvHgYtOU29J3uE%3D&reserved=0
>
> Is there a way I can get OVS 2.11.1 RPM to build successfully on Oracle LInux 7.8 and 7.9 and what is causing the problem?

Probably not - I haven't tried this or looked closely at the error but
it looks like a header has been moved or changed in some way.  The
'u8' type is fundamental to Linux so the header(s) that define it
must have changed.

You'll probably have to try a newer version of OVS. Is there some
particular reason you need 2.11.1 specifically?

- Greg


>
> Thanks,
>
> Gilbert Standen
> Contributor Orabuntu-LXC
>
>
>
>
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> https://eur05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmail.openvswitch.org%2Fmailman%2Flistinfo%2Fovs-discuss&data=04%7C01%7C%7Ca92119d3193748d1be3908d88a4f85b9%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637411421428266492%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Km%2FO0M0RYnBy2Agy%2F9LyxshZi7ss4I3ygiwkNf0VB68%3D&reserved=0
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20201116/0a0b6e46/attachment.html>


More information about the discuss mailing list