[ovs-discuss] Strongswan 5.8.2 compatibility issue

Bolesław Tokarski boleslaw.tokarski at gmail.com
Tue Sep 1 16:17:51 UTC 2020


Hi,

The bug I raised and solved in April 8th is still waiting for a review and
merge at https://github.com/openvswitch/ovs/pull/315

It is a simple configuration change. Please, integrate that to the code.

Regards,
Bolesław Tokarski


śr., 8 kwi 2020 o 17:21 Boleslaw Tokarski <boleslaw.tokarski at jolla.com>
napisał(a):

> The Strongswan configs put in /etc/strongswan.d/ovs.conf cause Strongswan
> to fail.
>
> What you did that make the problem appear?
>  - I upgraded Strongswan from 5.6.0 to 5.8.2
>
> What you expected to happen?
>  - Everything was supposed to work as it used to.
>
> What actually happened?
>  - openvswitch-ipsec failed to launch charon from strognswan
>  - manually running /usr/lib/ipsec/starter --daemoncharon produces:
>
> /etc/strongswan.d/ovs.conf:4: syntax error, unexpected ., expecting : or
> '{' or '=' [.]
> invalid config file '/etc/strongswan.conf'
> abort initialization due to invalid configuration
>
> I traced the error and managed to fix it with
> https://github.com/openvswitch/ovs/pull/315
> I tested this to work also on Strongswan 5.6.0.
>
> Best regards,
> Bolesław Tokarski
> Jolla Ltd
> _______________________________________________
> discuss mailing list
> discuss at openvswitch.org
> https://mail.openvswitch.org/mailman/listinfo/ovs-discuss
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20200901/ce138e7a/attachment.html>


More information about the discuss mailing list