[ovs-discuss] ovs-ofctl broken when getting table features reply

Dickens Yeh dickens.yeh at gmail.com
Fri Jan 8 05:00:36 UTC 2021


Hi Ben,
Thanks for your reply.

I can open it with Wireshark, decode as 'OpenFlow', and it shows info as
following(also in attachment file):
OFPT_HELLO,
OFPT_MULTIPART_REQUEST, OFPMP_FLOW
OFPT_MULTIPART_REPLY, OFPMP_FLOW
OFPT_HELLO,
OFPT_MULTIPART_REUQEST, OFPMP_TABLE_FEATURES
OFPT_MULTIPART_REPLY, OFPMP_TABLE_FEATURES

I also use your command to parse pcap file, I don't know why it shows
"OFPST_FLOW request" but there is no "OFPST_FLOW reply" message.
Maybe it cannot show the MULTIPART reply message, and the table features
reply didn't show with the same reason.

best wishes,
Dickens Yeh



Ben Pfaff <blp at ovn.org> 於 2021年1月8日 週五 上午3:36寫道:

> On Mon, Jan 04, 2021 at 11:13:53AM +0800, Dickens Yeh wrote:
> > Hi,
> > When I using the ovs-ofctl utility tool to dump flows from a
> > non-openvswitch switch without --no-names parameter, and I got error
> > message.
> >
> > cmd:
> >
> > ~/openvswitch-2.13.1/utilities/ovs-ofctl -O OpenFlow13 dump-flows tcp:
> > 192.168.17.166:6644
> >
> > msg:
> > 2020-12-31T10:12:22Z|00001|ofp_table|WARN|table features message missing
> > required property
> > ovs-ofctl: received bad reply: (***only uses 512 bytes out of 7056***)
> > 00000000  04 50 02 00 00 00 00 00-6e 6f 76 69 5f 74 61 62
> |.P......novi_tab|
> > 00000010  6c 65 5f 32 00 00 00 00-00 00 00 00 00 00 00 00
> |le_2............|
> > ...
> >
> > I also attached the pcap file, please tell me if the switch should be
> fixed
> > with the reply messages.
>
> I ran "ovs-ofctl ofp-parse-pcap dump-error.pcap 6644" and got only the
> following output:
>
>     192.168.13.141.52476 > 192.168.17.166.6644:
>     OFPT_HELLO (OF1.3) (xid=0x1):
>      version bitmap: 0x04
>
>     192.168.13.141.52476 > 192.168.17.166.6644:
>     OFPST_FLOW request (OF1.3) (xid=0x2):
>
>     192.168.13.141.52478 > 192.168.17.166.6644:
>     OFPT_HELLO (OF1.3) (xid=0x3):
>      version bitmap: 0x04
>
>     192.168.13.141.52478 > 192.168.17.166.6644:
>     OFPST_TABLE_FEATURES request (OF1.3) (xid=0x4):
>
> I don't think the table features reply is in the pcap.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20210108/158ba3d1/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: snapshot 2021-01-08 12.57.46 pm.png
Type: image/png
Size: 147439 bytes
Desc: not available
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20210108/158ba3d1/attachment-0001.png>


More information about the discuss mailing list