[ovs-discuss] ovs-ofctl broken when getting table features reply

Dickens Yeh dickens.yeh at gmail.com
Fri Jan 22 02:21:21 UTC 2021


Thanks for helping me.

I find the section in OF1.3.2 spec, and re-check with pcap file as you said.
I think I was missed the important message: "table features message missing
required property",
but only focus on "received bad reply: (***only uses 512 bytes out of
7056***)".

Thanks.

best wishes,
Dickens Yeh





Ben Pfaff <blp at ovn.org> 於 2021年1月22日 週五 上午6:44寫道:

> OK, I figured out the problem.
>
> Property 10, OFPTFPT_WILDCARDS, is missing.  OF1.3 section 7.3.5.5.2
> says that it's mandatory: "If a specific property does not have any
> capability (for example no Set-Field support), a property with an empty
> list must be included in the property list."  I think that OVS is
> correctly rejecting this set of table features.
>
> On Fri, Jan 08, 2021 at 01:00:36PM +0800, Dickens Yeh wrote:
> > Hi Ben,
> > Thanks for your reply.
> >
> > I can open it with Wireshark, decode as 'OpenFlow', and it shows info as
> > following(also in attachment file):
> > OFPT_HELLO,
> > OFPT_MULTIPART_REQUEST, OFPMP_FLOW
> > OFPT_MULTIPART_REPLY, OFPMP_FLOW
> > OFPT_HELLO,
> > OFPT_MULTIPART_REUQEST, OFPMP_TABLE_FEATURES
> > OFPT_MULTIPART_REPLY, OFPMP_TABLE_FEATURES
> >
> > I also use your command to parse pcap file, I don't know why it shows
> > "OFPST_FLOW request" but there is no "OFPST_FLOW reply" message.
> > Maybe it cannot show the MULTIPART reply message, and the table features
> > reply didn't show with the same reason.
> >
> > best wishes,
> > Dickens Yeh
> >
> >
> >
> > Ben Pfaff <blp at ovn.org> 於 2021年1月8日 週五 上午3:36寫道:
> >
> > > On Mon, Jan 04, 2021 at 11:13:53AM +0800, Dickens Yeh wrote:
> > > > Hi,
> > > > When I using the ovs-ofctl utility tool to dump flows from a
> > > > non-openvswitch switch without --no-names parameter, and I got error
> > > > message.
> > > >
> > > > cmd:
> > > >
> > > > ~/openvswitch-2.13.1/utilities/ovs-ofctl -O OpenFlow13 dump-flows
> tcp:
> > > > 192.168.17.166:6644
> > > >
> > > > msg:
> > > > 2020-12-31T10:12:22Z|00001|ofp_table|WARN|table features message
> missing
> > > > required property
> > > > ovs-ofctl: received bad reply: (***only uses 512 bytes out of
> 7056***)
> > > > 00000000  04 50 02 00 00 00 00 00-6e 6f 76 69 5f 74 61 62
> > > |.P......novi_tab|
> > > > 00000010  6c 65 5f 32 00 00 00 00-00 00 00 00 00 00 00 00
> > > |le_2............|
> > > > ...
> > > >
> > > > I also attached the pcap file, please tell me if the switch should be
> > > fixed
> > > > with the reply messages.
> > >
> > > I ran "ovs-ofctl ofp-parse-pcap dump-error.pcap 6644" and got only the
> > > following output:
> > >
> > >     192.168.13.141.52476 > 192.168.17.166.6644:
> > >     OFPT_HELLO (OF1.3) (xid=0x1):
> > >      version bitmap: 0x04
> > >
> > >     192.168.13.141.52476 > 192.168.17.166.6644:
> > >     OFPST_FLOW request (OF1.3) (xid=0x2):
> > >
> > >     192.168.13.141.52478 > 192.168.17.166.6644:
> > >     OFPT_HELLO (OF1.3) (xid=0x3):
> > >      version bitmap: 0x04
> > >
> > >     192.168.13.141.52478 > 192.168.17.166.6644:
> > >     OFPST_TABLE_FEATURES request (OF1.3) (xid=0x4):
> > >
> > > I don't think the table features reply is in the pcap.
> > >
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.openvswitch.org/pipermail/ovs-discuss/attachments/20210122/8528b84d/attachment.html>


More information about the discuss mailing list