<div dir="ltr"><div>Bumping this thread as its been a while.</div><div><br></div><div>Anyone see any issues similar to this?  We're still working around it with the lower MTU.</div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Tue, Jul 9, 2019 at 8:43 AM Liam Young <<a href="mailto:liam.young@canonical.com">liam.young@canonical.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr">Hi,<br><br>I have a server which has an ovs bridge with a dpdk device attached<br>for external network access and a network namespace attached via a tap<br>device. Sending data out of the namespace fails if jumbo frames are enabled.<br>Sending data into the namespace seems ok.  Dropping the mtu of the tap device<br>in the network namespace to 1500 also seems to fix the issue.<br><br>I initially came across the issue in an OpenStack deployment and raised<br>Bug #1833713 *1. However, I was able to reproduce the issue without<br>OpenStack by manually creating the bridge etc *2.<br><br>Any advice, tips or you-missed-this-step very gratefully received,<br>Liam<br><br>Below is my setup:<br><br>Ubuntu: eoan<br>DPDK pkg: 18.11.1-3<br>OVS DPDK pkg: 2.11.0-0ubuntu2<br>Kerenl: 5.0.0-20-generic<br><br>root@node-licetus:~# ovs-vsctl show<br>523eab62-8d03-4445-a7ba-7570f5027ff6<br>    Bridge br-test<br>        Port "tap1"<br>            Interface "tap1"<br>                type: internal<br>        Port br-test<br>            Interface br-test<br>                type: internal<br>        Port "dpdk-nic1"<br>            Interface "dpdk-nic1"<br>                type: dpdk<br>                options: {dpdk-devargs="0000:03:00.0"}<br>    ovs_version: "2.11.0"<br><br>root@node-licetus:~# ovs-vsctl get Interface dpdk-nic1 mtu<br>9000<br><br>root@node-licetus:~# ip netns exec ns1 ip addr show tap1<br>12: tap1: <BROADCAST,MULTICAST,PROMISC,UP,LOWER_UP> mtu 9000 qdisc fq_codel state UNKNOWN group default qlen 1000<br>    link/ether 0a:dd:76:38:52:54 brd ff:ff:ff:ff:ff:ff<br>    inet <a href="http://10.246.112.101/21" target="_blank">10.246.112.101/21</a> scope global tap1<br>       valid_lft forever preferred_lft forever<br>    inet6 fe80::8dd:76ff:fe38:5254/64 scope link<br>       valid_lft forever preferred_lft forever<br><br>Using iperf to send data out of the netns fails:<br><br>root@node-licetus:~# ip netns exec ns1 iperf -c 10.246.114.29<br>------------------------------------------------------------<br>Client connecting to 10.246.114.29, TCP port 5001<br>TCP window size: 325 KByte (default)<br>------------------------------------------------------------<br>[ 3] local 10.246.112.101 port 51590 connected with 10.246.114.29 port 5001<br>[ ID] Interval Transfer Bandwidth<br>[ 3] 0.0-10.3 sec 323 KBytes 257 Kbits/sec<br><br><br>root@node-hippalus:~# iperf -s -m<br>------------------------------------------------------------<br>Server listening on TCP port 5001<br>TCP window size: 128 KByte (default)<br>------------------------------------------------------------<br>root@node-hippalus:~#<br><br><br><br>*1 <a href="https://bugs.launchpad.net/ubuntu/+source/dpdk/+bug/1833713" target="_blank">https://bugs.launchpad.net/ubuntu/+source/dpdk/+bug/1833713</a><br>*2 <a href="https://bugs.launchpad.net/ubuntu/+source/dpdk/+bug/1833713/comments/7" target="_blank">https://bugs.launchpad.net/ubuntu/+source/dpdk/+bug/1833713/comments/7</a><br></div>
_______________________________________________<br>
discuss mailing list<br>
<a href="mailto:discuss@openvswitch.org" target="_blank">discuss@openvswitch.org</a><br>
<a href="https://mail.openvswitch.org/mailman/listinfo/ovs-discuss" rel="noreferrer" target="_blank">https://mail.openvswitch.org/mailman/listinfo/ovs-discuss</a><br>
</blockquote></div></div>