[ovs-git] Open vSwitch: in-band: Use NULL for null pointer constant, instead of 0. (master)

dev at openvswitch.org dev at openvswitch.org
Mon Apr 26 16:51:40 UTC 2010


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  bad0c37193b4697cec1b6d5f1afb3413edbd9c3c (commit)
       via  a3c5ac709a32ad802534b6039fd8f762910d19d6 (commit)
       via  c16e55cf846f7a04a28730e25193d6a8ccd95f11 (commit)
       via  5dbdfff733b4833397feba64047dabac9bb36531 (commit)
       via  6dee2066b5edaa9b5c7af572d075591ad595428d (commit)
      from  375008d8769d35ea58343a0a57bb757f5a77fcad (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit bad0c37193b4697cec1b6d5f1afb3413edbd9c3c
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=bad0c37193b4697cec1b6d5f1afb3413edbd9c3c
Author: Ben Pfaff <blp at nicira.com>
		
in-band: Use NULL for null pointer constant, instead of 0.
		
Suggested-by: Justin Pettit <jpettit at nicira.com>


commit a3c5ac709a32ad802534b6039fd8f762910d19d6
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=a3c5ac709a32ad802534b6039fd8f762910d19d6
Author: Ben Pfaff <blp at nicira.com>
		
in-band: Refactor in_band_set_remotes().
		
Seems easier to understand this way.

Suggested-by: Justin Pettit <jpettit at nicira.com>


commit c16e55cf846f7a04a28730e25193d6a8ccd95f11
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=c16e55cf846f7a04a28730e25193d6a8ccd95f11
Author: Ben Pfaff <blp at nicira.com>
		
in-band: Refactor slightly to be easier to understand.
		
Suggested-by: Justin Pettit <jpettit at nicira.com>


commit 5dbdfff733b4833397feba64047dabac9bb36531
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=5dbdfff733b4833397feba64047dabac9bb36531
Author: Ben Pfaff <blp at nicira.com>
		
in-band: Avoid magic number in refresh_remotes().
		
The initial value of min_refresh() can only matter if there are no remotes,
in which case there is nothing to refresh anyhow.  So avoid the magic
number "10" as the initial minimum, since it has no real significance.

Suggested-by: Justin Pettit <jpettit at nicira.com>


commit 6dee2066b5edaa9b5c7af572d075591ad595428d
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=6dee2066b5edaa9b5c7af572d075591ad595428d
Author: Ben Pfaff <blp at nicira.com>
		
in-band: Better adapt to new rconn usage pattern.
		
Previously, in-band control was always handed a single rconn whose remote
target changed as the selected controller was changed or added or removed.
Now, however, the rconns handed to in-band control never change their
remote IP targets (instead, new rconns are added and old ones are removed),
so there is no point in looking for changes in remote IP address.

Suggested-by: Justin Pettit <jpettit at nicira.com>


-----------------------------------------------------------------------

Summary of changes:
 ofproto/in-band.c |  106 +++++++++++++++++++++++++++++-----------------------
 1 files changed, 59 insertions(+), 47 deletions(-)


hooks/post-receive
-- 
Open vSwitch




More information about the git mailing list