[ovs-git] Open vSwitch: Fix "make dist" by adding include/linux/types.h to distribution. (master)

dev at openvswitch.org dev at openvswitch.org
Mon Dec 6 18:44:38 UTC 2010


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Open vSwitch".

The branch, master has been updated
       via  20d9a814c745494d5afa335352b666ad6947661f (commit)
       via  dfdfc8d43d102f4b5851d26773c1786ee2b13877 (commit)
       via  d1e2cf211901ec64dc2f91ab5379a0ac2654ae62 (commit)
       via  c24750a10235af1be9fd9196fc026ab4626ba2d4 (commit)
       via  531edfbb427fd7f3287d8e6412b115e2cf6dc558 (commit)
       via  7f009380f61edda538c4c4d6333a14014258ca8f (commit)
       via  b3907fbc6c74ddad7507d0f7abb1f5a2528cd2be (commit)
       via  772ec52b896380f23b587bea4a5bf18edd22449d (commit)
      from  7c9b00732c633ddd35b9d92fb9fa4c4f8e3ce390 (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 20d9a814c745494d5afa335352b666ad6947661f
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=20d9a814c745494d5afa335352b666ad6947661f
Author: Ben Pfaff <blp at nicira.com>
		
Fix "make dist" by adding include/linux/types.h to distribution.
		


commit dfdfc8d43d102f4b5851d26773c1786ee2b13877
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=dfdfc8d43d102f4b5851d26773c1786ee2b13877
Author: Ben Pfaff <blp at nicira.com>
		
ofp-util: New functions for creating Nicira extension messages.
		


commit d1e2cf211901ec64dc2f91ab5379a0ac2654ae62
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=d1e2cf211901ec64dc2f91ab5379a0ac2654ae62
Author: Ben Pfaff <blp at nicira.com>
		
Refactor and centralize basic OpenFlow message decoding and validation.
		
Open vSwitch contains a few different chunks of code that need to decode
an OpenFlow message to determine its type and then validate that it is
long enough.  Until now, the code for doing this has been more or less
scattered across the tree.  Whenever a new piece of code needed to do this,
it generally needed to reimplement at least part of it.

This commit centralizes all of that work into a single function,
ofputil_decode_msg_type(), and helper functions, and converts all of the
code that was decoding messages by hand to use the new function.


commit c24750a10235af1be9fd9196fc026ab4626ba2d4
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=c24750a10235af1be9fd9196fc026ab4626ba2d4
Author: Ben Pfaff <blp at nicira.com>
		
port-array: Remove.
		
This code had no remaining users.


commit 531edfbb427fd7f3287d8e6412b115e2cf6dc558
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=531edfbb427fd7f3287d8e6412b115e2cf6dc558
Author: Ben Pfaff <blp at nicira.com>
		
pinsched: Use hmap instead of port_array.
		
This is the last remaining use of port_array in the tree.  It wasn't really
taking advantage of any of the special features of port_arrays, so it's
better to save some time and memory by using an hmap instead.

(In addition, OpenFlow 1.1, which we may eventually want to support, has
changed from 16-bit to 32-bit port numbers, which would require the
port_array code to be rewritten anyhow.)


commit 7f009380f61edda538c4c4d6333a14014258ca8f
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=7f009380f61edda538c4c4d6333a14014258ca8f
Author: Ben Pfaff <blp at nicira.com>
		
vconn: New function vconn_transact_multiple_noreply().
		
This will be useful for sending a bunch of flow_mod messages all at once.


commit b3907fbc6c74ddad7507d0f7abb1f5a2528cd2be
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=b3907fbc6c74ddad7507d0f7abb1f5a2528cd2be
Author: Ben Pfaff <blp at nicira.com>
		
queue: Get rid of ovs_queue data structure.
		
ovs_queue doesn't seem very useful; it's just a singly-linked list.  It's
more generally useful to use a general-purpose "struct list" for lists of
packets, so this commit adds such a member to "struct ofpbuf" and shifts
the existing users to use it.


commit 772ec52b896380f23b587bea4a5bf18edd22449d
Diffs: http://openvswitch.org/cgi-bin/gitweb.cgi?p=openvswitch;a=commitdiff;h=772ec52b896380f23b587bea4a5bf18edd22449d
Author: Ben Pfaff <blp at nicira.com>
		
util: Introduce ASSIGN_CONTAINER to make iteration macros easier to read.
		


-----------------------------------------------------------------------

Summary of changes:
 include/linux/automake.mk  |    4 +-
 lib/automake.mk            |    4 -
 lib/classifier.h           |   16 +-
 lib/dpif-netdev.c          |   37 ++-
 lib/hmap.h                 |   29 +--
 lib/jsonrpc.c              |   22 +-
 lib/learning-switch.c      |  160 ++++++-----
 lib/learning-switch.h      |    8 +-
 lib/list.c                 |   10 +-
 lib/list.h                 |   20 +-
 lib/ofp-print.c            |  718 +++++++++++++++++++-------------------------
 lib/ofp-util.c             |  665 +++++++++++++++++++++++++++++++++++------
 lib/ofp-util.h             |   88 +++++-
 lib/ofpbuf.c               |   15 +-
 lib/ofpbuf.h               |    9 +-
 lib/port-array.c           |  194 ------------
 lib/port-array.h           |   96 ------
 lib/queue.c                |  120 --------
 lib/queue.h                |   44 ---
 lib/rconn.c                |   40 ++-
 lib/rconn.h                |    1 -
 lib/util.h                 |    8 +
 lib/vconn.c                |   25 ++
 lib/vconn.h                |    3 +
 ofproto/ofproto.c          |  432 +++++++++++----------------
 ofproto/pinsched.c         |  130 ++++++---
 ofproto/status.c           |    3 +-
 ofproto/status.h           |    8 +-
 tests/ofproto.at           |    8 +-
 tests/ovs-ofctl.at         |   18 +-
 utilities/ovs-controller.c |   10 +-
 31 files changed, 1489 insertions(+), 1456 deletions(-)
 delete mode 100644 lib/port-array.c
 delete mode 100644 lib/port-array.h
 delete mode 100644 lib/queue.c
 delete mode 100644 lib/queue.h


hooks/post-receive
-- 
Open vSwitch




More information about the git mailing list